Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159782 - In the Dirextory Server Gateway, some links have the wrong port number in them
Summary: In the Dirextory Server Gateway, some links have the wrong port number in them
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: UI - Gateway/Phonebook
Version: 7.1
Hardware: i386
OS: Linux
urgent
high
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 22:10 UTC by Ade
Modified: 2015-12-07 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 16:55:22 UTC


Attachments (Terms of Use)

Description Ade 2005-06-07 22:10:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Certain links in the Directory Server Gateway link to port number 39083 but should point to port 43456

For example, search for an existing user in Directory Server Gateway, using simple search. Once you have found a user, click on him - the users unfo is displayed, but if you click on the "org chart" icon (next to the vcard icon) you will see that the link has port 39083 in it and doesnt work. If you edit this in the address bar to 43456, the page displays

Version-Release number of selected component (if applicable):
fedora-ds-7.1-2.RHEL3

How reproducible:
Always

Steps to Reproduce:
1.search for an existing user in Directory Server Gateway
2.click on him
3.hover over "org chart" icon and look in status bar (or click icon)
  

Actual Results:  The url has port 39083 in it

Expected Results:  the port number should be 43456

Additional info:

Comment 2 Rich Megginson 2008-02-29 22:48:27 UTC
I can't reproduce this with the latest code.  I did fix some issues with
incorrect URL generation.

Comment 3 Anh Nguyen 2008-06-20 16:58:01 UTC
Looks like there is a regression here - clicking the org chart icon resulting in
 'no search results found'. This appears to be due to incorrect 'base' spec. See
below.

Here is what I did, and the according results:
1. <advance search>
2. find <person> where name is <*>;  # This listed a list of people
3. click on a person, e.g., <awhite>, and <orgchart> icon  # this returned a 'No
search results found!'
4. check access log - 

[20/Jun/2008:09:38:04 -0700] conn=36 op=2 SRCH base="dc=dsqa, dc=sjc2,
dc=redhat, dc=com" scope=2 filter="(|(cn=*awhite*)(mail=*awhite*))"
attrs="businessCategory cn dn mail manager objectClass ou telephoneNumber title uid"
[20/Jun/2008:09:38:04 -0700] conn=36 op=2 RESULT err=0 tag=101 nentries=0 etime=0

5. the base should have been "dc=example,dc=com"

6. raise priority and serverity


Comment 4 Anh Nguyen 2008-06-20 16:58:15 UTC
Looks like there is a regression here - clicking the org chart icon resulting in
 'no search results found'. This appears to be due to incorrect 'base' spec. See
below.

Here is what I did, and the according results:
1. <advance search>
2. find <person> where name is <*>;  # This listed a list of people
3. click on a person, e.g., <awhite>, and <orgchart> icon  # this returned a 'No
search results found!'
4. check access log - 

[20/Jun/2008:09:38:04 -0700] conn=36 op=2 SRCH base="dc=dsqa, dc=sjc2,
dc=redhat, dc=com" scope=2 filter="(|(cn=*awhite*)(mail=*awhite*))"
attrs="businessCategory cn dn mail manager objectClass ou telephoneNumber title uid"
[20/Jun/2008:09:38:04 -0700] conn=36 op=2 RESULT err=0 tag=101 nentries=0 etime=0

5. the base should have been "dc=example,dc=com"

6. raise priority and serverity

Comment 5 Rich Megginson 2008-06-20 19:40:30 UTC
Why should the base have been dc=example,dc=com?  Note that the orgchart.conf
file has its own base suffix config, which must be kept in sync with any changes
to dsgw.conf and pb.conf

Comment 6 Anh Nguyen 2008-06-24 19:18:00 UTC
Search for a person; Moved cursor over the orgchar; correct link and port were
observed. Marking this bug VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.