Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159769 - kernel crash while loading modules
Summary: kernel crash while loading modules
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mkinitrd
Version: 4.0
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Brian Lane
QA Contact: Kevin Baker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 20:57 UTC by Andrew Elmore
Modified: 2014-12-01 23:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-27 17:57:41 UTC


Attachments (Terms of Use)

Description Andrew Elmore 2005-06-07 20:57:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.5) Gecko/20050131

Description of problem:
in the init script in /boot/initrd....img, a sequence of insmod commands gets invoked in parallel.  I'm not sure how this happens, but the upshot is that the 6 modules for the scsi subsystem and the boot filesystem aren't able to be loaded due to their dependencies being unresolved.  the real init isn't able to be invoked, and the system crashes.  Putting "sleep 2" in between each of the insmods fixed the problem for me.  The real fix would be for the Linux kernel to serialize module instantiation.

note that this is a 4 way SMP box (an IBM RS/6000 7044-270).

Version-Release number of selected component (if applicable):
n/a

How reproducible:
Always

Steps to Reproduce:
1. reboot after install.
2.
3.
  

Actual Results:  system crashed.

Expected Results:  I would expect the system to come up properly.

Additional info:

Comment 1 Bill Nottingham 2005-06-07 21:03:24 UTC
Assigning to kernel, cc'ing mkinitrd maintainer.

Comment 2 Dave Jones 2005-06-21 17:51:24 UTC
That script is firmly in the realm of mkinitrd, reassigning.



Note You need to log in before you can comment on or make changes to this bug.