Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597665 - [Logs] Make ODL Log to file for containarised deployments
Summary: [Logs] Make ODL Log to file for containarised deployments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 13.0 (Queens)
Assignee: Janki
QA Contact: Tomas Jamrisko
URL:
Whiteboard: Logs
: 1597959 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-03 11:49 UTC by Janki
Modified: 2018-12-24 11:40 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-45.el7ost
Doc Type: Bug Fix
Doc Text:
Docker used journald backend rolls over logs based on size. This resulted in the deletion of some of the older OpenDaylight logs. This issue has been resolved by moving to logging to file instead of console where log file size and rollover can be managed by OpenDaylight. As a result, older logs are persistent for a longer duration than before.
Clone Of:
Environment:
N/A
Last Closed: 2018-08-29 16:37:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1779627 None None None 2018-07-03 11:49:51 UTC
OpenStack gerrit 579494 None None None 2018-07-03 11:50:26 UTC
Red Hat Product Errata RHBA-2018:2574 None None None 2018-08-29 16:38:52 UTC

Description Janki 2018-07-03 11:49:52 UTC
Description of problem:
ODL currently logs to console and the logs are available on overcloud nodes via docker logs. Sometimes, older logs are deleted due to journal rollover. This can make debugging difficult with incomplete logs.

Version-Release number of selected component (if applicable):
OSP13-Oxygen

How reproducible:
Sometimes

Steps to Reproduce:
1. Deploy OSP13+ODL
2. Create some resources, keep the deployment running
3. Check for older logs after 2 days generally

Actual results:
Logs from 2 days before are gone

Expected results:
Logs from the start of the ODL container should persist.

Additional info:

Comment 2 Nir Yechiel 2018-07-04 10:14:30 UTC
*** Bug 1597959 has been marked as a duplicate of this bug. ***

Comment 12 Janki 2018-08-01 11:18:07 UTC
To verify:

Ensure there are karaf log files at /var/log/containers/opendaylight/. There would be 2 files each with 10GB size. Once karaf.log is of 10GB in size, karfa.log.1 will be created. Once its 10GB in size, content in karaf.log will be over-written.

Comment 13 Joanne O'Flynn 2018-08-15 07:56:38 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 17 errata-xmlrpc 2018-08-29 16:37:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2574


Note You need to log in before you can comment on or make changes to this bug.