Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597660 - firefox fails to update to 60.1.0-4.el7_5.x86_64
Summary: firefox fails to update to 60.1.0-4.el7_5.x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-03 11:27 UTC by Tomas Hudziec
Modified: 2018-07-03 11:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-03 11:35:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tomas Hudziec 2018-07-03 11:27:40 UTC
Description of problem:
Firefox update from firefox-60.0-0.2.el7.x86_64 to firefox-60.1.0-4.el7_5.x86_64 fails due to error while unpacking rpm package, particularly on file /usr/lib64/firefox/browser/defaults/preferences: cpio: rename.

Version-Release number of selected component (if applicable):
firefox-60.1.0-4.el7_5.x86_64

How reproducible:
always

Steps to Reproduce:
1. have firefox-60.0-0.2.el7.x86_64 (or maybe some other version < 60.1.0-4) installed
2. update it with yum to firefox-60.1.0-4.el7_5.x86_64

Actual results:
Update fails with errors:
Error unpacking rpm package firefox-60.1.0-4.el7_5.x86_64
error: unpacking of archive failed on file /usr/lib64/firefox/browser/defaults/preferences: cpio: rename

error: firefox-60.1.0-4.el7_5.x86_64: install failed
error: firefox-60.0-0.2.el7.x86_64: erase skipped
firefox-60.0-0.2.el7.x86_64 was supposed to be removed but is not!

Expected results:
smooth update to firefox-60.1.0-4.el7_5.x86_64

Comment 2 Tomas Pelka 2018-07-03 11:35:57 UTC
Closing as we never released ESR60.0 and customer is actually doing update from ESR52.8 to ESR60.1 and in fact even there was a bz related to cpio: rename customer can't trigger it.


Note You need to log in before you can comment on or make changes to this bug.