Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159754 - cluster lvm rpm should adjust the locking type on install to enable cluster operations
Summary: cluster lvm rpm should adjust the locking type on install to enable cluster o...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: AJ Lewis
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 158231
TreeView+ depends on / blocked
 
Reported: 2005-06-07 20:02 UTC by AJ Lewis
Modified: 2010-01-12 04:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-10 20:15:25 UTC


Attachments (Terms of Use)

Description AJ Lewis 2005-06-07 20:02:46 UTC
+++ This bug was initially created as a clone of Bug #158231, and addresses
point 4 (2) of that bug's original message +++

Description of problem:

Rob Kenna, Jonathan Brassow, and Lon Hohberger put togather a RHEL 4 cluster/GFS
class on 5/18/05 with a hand-on lab exercise for GSS group. This bugzilla
documents one of the problems (on system-config-lvm) we found during the exercise.

Though most of them were trivial issues, these do represent the "look and feel"
of the product that real customers are going to see.                           
                               
 
Editing of /etc/lvm/lvm.conf File
   (severity low)(not a bug but a usability issue)
                                                                                
1 It is not clear (to us) that the /etc/lvm/lvm.conf file need to get edited
on *every* node in the same GFS cluster.
2 Jumping in/out of GUI (system-config-lvm) to add the following lines into
lvm configuration file is awkward.
                                                                                
    # Type of locking to use. Defaults to file-based locking (1).
    # Turn locking off by setting to 0 (dangerous: risks metadata corruption
    # if LVM2 commands get run concurrently).
    locking_type = "2"
    locking_library = "/usr/lib/liblvm2clusterlock.so"

It would be nice to include the above into system-config-lvm tool (consider
this as a feature request). On the other hand, make really sure this is
documented in SysAdmin guide (if we have one).

Comment 1 AJ Lewis 2005-06-07 20:04:24 UTC
The plan is to handle this by adding post/postun scripts to the clvm rpm to add
and remove, respectively, the locking type change required for clustered
operation to work with lvm2.

Comment 2 AJ Lewis 2005-06-10 20:03:26 UTC
A modified version of the clvmd_fix_conf.sh script has been checked into
upstream cvs, called lvmconf, that handles adding and removing the clvm enabling
config file options.  This script will be run by the lvm2-cluster %post
scriptlet to enable clvm, and the %preun scriptlet to remove it if the user is
uninstalling the package.

Comment 3 AJ Lewis 2005-06-10 20:15:25 UTC
This fix is in lvm2-cluster-2.01.09-4.0.RHEL4 which should be in RHEL4-U2.


Note You need to log in before you can comment on or make changes to this bug.