Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159749 - Bugs in handle striped LVM volumes
Summary: Bugs in handle striped LVM volumes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact: Brian Brock
URL: http://lkml.org/lkml/2005/5/18/251
Whiteboard:
: 165585 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 19:06 UTC by Morgan Nilsson
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 07:17:49 UTC


Attachments (Terms of Use)

Description Morgan Nilsson 2005-06-07 19:06:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I have 6 lvm2 based filsystems. 3 are using striping over raid. All of them started to contain damaged files after we reboot to use the new kernel (kernel-smp-2.6.11-1.27_FC3). Before we had 2.6.10.

From /var/log/messages:

kernel: attempt to access beyond end of device
kernel: dm-6: rw=0, want=8390664, limit=8388608
...


Version-Release number of selected component (if applicable):
kernel-smp-2.6.11-1.27_FC3

How reproducible:
Didn't try

Steps to Reproduce:
1. Create an lvm2 raid1 volume with striping (-i 2, or so)
2. Create a ext3 filesystem (mkfs -t ext3 ...)


  

Actual Results:  Files could not be copied, textfiles contained binary data, and was missing parts of information.

Expected Results:  I expected lvm2 + stripe over raid1 not to corrupy my filesystem.


Additional info:

Comment 1 Morgan Nilsson 2005-06-07 19:09:25 UTC
I mean that all the stripes filesystems contained corrupt files. The other
non-striped lvm2 raid1 filesystems were OK.


Comment 2 Alasdair Kergon 2005-07-05 20:12:37 UTC
How large are the filesystems?


Comment 3 Alasdair Kergon 2005-07-05 20:19:57 UTC
I'm aware of some problems with older kernels and large stripes, and with mixing
lvm2 and raid in specific ways - but those problems got fixed in upstream
kernels several months ago and I've not heard of any problems recently.

Comment 4 Dave Jones 2005-07-15 18:53:56 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 5 Morgan Nilsson 2005-07-24 10:59:29 UTC
OK, thanks.

I will test when our spare computer becomes available.

File system sizes:
/dev/mapper/VolGroup00-Root: 13 GB
/dev/mapper/VolGroup00-Home: 17 GB
/dev/mapper/VolGroup00-Work: 9.9 GB



Comment 6 Alasdair Kergon 2005-08-08 15:38:10 UTC
And another possible cause, a kernel bug ('bio->bi_idx = bio_src->bi_idx'
missing from bio_clone in fs/bio.c) found and fixed upstream in 2.6.13-rc4.

Comment 7 Dave Jones 2005-08-09 20:40:42 UTC
that bug is fixed in the latest errata kernels in testing, though they've not
been pushed out publically yet for some reason.  In the meantime, you can find
them at http://people.redhat.com/davej/kernels/Fedora/

Comment 8 Alasdair Kergon 2005-08-10 16:37:12 UTC
*** Bug 165585 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.