Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597484 - on a greenfield OCP + CNS deployment, pods in default project is not configured [NEEDINFO]
Summary: on a greenfield OCP + CNS deployment, pods in default project is not configured
Keywords:
Status: NEW
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.10.z
Assignee: Jose A. Rivera
QA Contact: krishnaram Karthick
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-03 03:44 UTC by krishnaram Karthick
Modified: 2018-08-17 04:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:
kramdoss: needinfo? (jrivera)


Attachments (Terms of Use)
hosts inventory file (deleted)
2018-07-03 03:51 UTC, krishnaram Karthick
no flags Details

Description krishnaram Karthick 2018-07-03 03:44:25 UTC
Description of problem:
When OCP + CNS is configured via ansible as a greenfield deployment, pods in default project is not configured. ie., router, registry console & docker registry.

However with the same inventory file, when deploy_cluster is run commenting out glusterfs section, these pods are configured properly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run deploy_cluster playbook with glusterfs section defined
2. check if pods in default project is deployed
3.

Actual results:
with ocp_cns greenfield deployment, pods in default project is not spun up

Expected results:
with ocp_cns greenfield deployment, pods in default project should be configured

Additional info:

Comment 1 krishnaram Karthick 2018-07-03 03:47:42 UTC
Missed out to add the version details,

Version-Release number of selected component (if applicable):
openshift v3.10.10
kubernetes v1.10.0+b81c8f8

Comment 2 krishnaram Karthick 2018-07-03 03:51:12 UTC
Created attachment 1456094 [details]
hosts inventory file

Comment 4 Scott Dodson 2018-07-03 12:12:29 UTC
Do the pods not exist or are they failing for some reason? If they're failing can you debug why they're failing?


Note You need to log in before you can comment on or make changes to this bug.