Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159748 - No icon for automounted devices
Summary: No icon for automounted devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gamin
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
: 160886 162968 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 19:02 UTC by David Zeuthen
Modified: 2017-10-10 19:19 UTC (History)
4 users (show)

Fixed In Version: 0.1.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-11 22:52:07 UTC


Attachments (Terms of Use)

Description David Zeuthen 2005-06-07 19:02:13 UTC
Description of problem:

When I hotplug a USB storage device, I don't get any icon on the desktop even
though the device is mounted. Downgrading to gamin-0.0.26-1 make things work.

Version-Release number of selected component (if applicable):

gamin-0.1.0-1.1 and a Fedora Rawhide system fully updated Mon Jun 6 2005. Should
also affect FC4.

How reproducible:

Always (also had a collegue (jrb) reproduce this).

Steps to Reproduce:
1. Log in to the GNOME desktop
2. Plug in USB storage device
  
Actual results:

There appears an icon in computer:/// in Nautilus for the storage device but it
isn't the one for a mounted disk

Expected results:

Icon in computer:/// should change to that of the storage device but in the
mounted state.

Additional info:

From a technical point of view, all this means that
/usr/libexec/gnome-vfs-daemon doesn't catch the change in /etc/mtab that occurs
when gnome-volume-manager is invoking mount(1) (and mount(1) updates
the /etc/mtab file). It's most likely a race condition of some sort.

Of course, there is the possibility that this is a bug with
gnome-vfs but since it works with gamin-0.0.26-1 (and fam before the gamin era)
I doubt it.

This was initially reported in bug 149199 since I mixed it up with another bug
report - Sorry.

Comment 1 Daniel Veillard 2005-06-08 20:18:58 UTC
To avoid getting into the technical intricacies of that one let's just
summarize as "dnotify sucks".
I think I have a fix in gnome CVS head, but it's a rather large patch, 
I need to make a new release, that I will push as a FC-4 update as 
we are freezed at this point.

Daniel


Comment 2 David Zeuthen 2005-06-20 15:33:52 UTC
*** Bug 160886 has been marked as a duplicate of this bug. ***

Comment 3 David Zeuthen 2005-07-11 22:49:48 UTC
*** Bug 162968 has been marked as a duplicate of this bug. ***

Comment 4 David Zeuthen 2005-07-11 22:52:07 UTC
Daniel, I'm closing this as ERRATA since a version that fixed this is available
in Rawhide / FC4 updates. Hope that is OK.

Comment 5 Daniel Veillard 2005-07-11 23:02:39 UTC
Sure, thanks !

Daniel


Note You need to log in before you can comment on or make changes to this bug.