Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597435 - [BACKPORT] Cinder service is failing on NetApp with SVM admin scoped account [NEEDINFO]
Summary: [BACKPORT] Cinder service is failing on NetApp with SVM admin scoped account
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: zstream
: 12.0 (Pike)
Assignee: Eric Harney
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-02 22:57 UTC by David Vallee Delisle
Modified: 2019-02-17 03:15 UTC (History)
11 users (show)

Fixed In Version: openstack-cinder-11.1.0-15.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-05 18:49:12 UTC
Target Upstream Version:
tshefi: automate_bug-
amcleod: needinfo? (eharney)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1694579 None None None 2018-07-02 22:57:47 UTC
OpenStack gerrit 572382 None None None 2018-07-02 22:58:18 UTC
Red Hat Product Errata RHBA-2018:3785 None None None 2018-12-05 18:49:43 UTC

Description David Vallee Delisle 2018-07-02 22:57:01 UTC
Description of problem:
Cinder service is failing below:

2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode Traceback (most recent call last):
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/dataontap/performance/perf_cmode.py", line 46, in _init_counter_info
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode     'avg_processor_busy'))
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/dataontap/performance/perf_base.py", line 224, in _get_base_counter_name
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode     object_name, counter_name)
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode   File "/usr/lib/python2.7/site-packages/cinder/utils.py", line 830, in trace_method_logging_wrapper
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode     return f(*args, **kwargs)
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/dataontap/client/client_base.py", line 289, in get_performance_counter_info
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode     enable_tunneling=False)
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode   File "/usr/lib/python2.7/site-packages/cinder/utils.py", line 830, in trace_method_logging_wrapper
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode     return f(*args, **kwargs)
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/dataontap/client/client_base.py", line 90, in send_request
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode     return self.connection.invoke_successfully(request, enable_tunneling)
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/dataontap/client/api.py", line 222, in invoke_successfully
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode     raise NaApiError(code, msg)
2018-07-02 22:16:08.453 668547 ERROR cinder.volume.drivers.netapp.dataontap.performance.perf_cmode NaApiError: NetApp API failed. Reason - 13001:Object "system:constituent" was not found.

This issue appears to be fixed in cinder 11.1.1 [1]. As such we are requesting packages if a backport has been created for OSP 12.

Thank You,

[1]
https://bugs.launchpad.net/cinder/+bug/1694579
https://docs.openstack.org/releasenotes/cinder/pike.html

Version-Release number of selected component (if applicable):

openstack-cinder-11.1.0-1.el7ost.noarch

How reproducible:
All the time

Comment 1 Red Hat Bugzilla Rules Engine 2018-07-02 23:30:42 UTC
This bugzilla has been removed from the release since it has not been triaged, and needs to be reviewed for targeting another release.

Comment 17 Tzach Shefi 2018-12-05 14:20:20 UTC
NetApp backend specific issue,
Not going to invest automation effort on close loop case.

Comment 19 errata-xmlrpc 2018-12-05 18:49:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3785


Note You need to log in before you can comment on or make changes to this bug.