Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597394 - vigra-1.11.1-8.fc29 FTBFS [NEEDINFO]
Summary: vigra-1.11.1-8.fc29 FTBFS
Keywords:
Status: CLOSED DUPLICATE of bug 1606645
Alias: None
Product: Fedora
Classification: Fedora
Component: vigra
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Postle
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON37
TreeView+ depends on / blocked
 
Reported: 2018-07-02 20:41 UTC by Miro Hrončok
Modified: 2018-07-23 13:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-23 13:43:27 UTC
mhroncok: needinfo? (bruno)


Attachments (Terms of Use)

Description Miro Hrončok 2018-07-02 20:41:03 UTC
On rawhide, after update to Python 3.7, vigra fails to build with:

/builddir/build/BUILD/vigra-1.11.1/vigranumpy/src/core/vigranumpycore.cxx: In function 'vigra::UInt32 vigra::pychecksum(const boost::python::str&)':
/builddir/build/BUILD/vigra-1.11.1/vigranumpy/src/core/vigranumpycore.cxx:64:39: error: invalid conversion from 'const char*' to 'char*' [-fpermissive]
  char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
                ~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~

This was common error during the 3.7 rebuilds. Change data to const char* to fix it.

Comment 1 Miro Hrončok 2018-07-17 12:34:59 UTC
Bruno?

Comment 2 Miro Hrončok 2018-07-23 13:43:27 UTC

*** This bug has been marked as a duplicate of bug 1606645 ***


Note You need to log in before you can comment on or make changes to this bug.