Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597363 - SSA failure for Windows instance: undefined local variable or method `fs'
Summary: SSA failure for Windows instance: undefined local variable or method `fs'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Hui Song
QA Contact: Brandon Squizzato
URL:
Whiteboard:
: 1594149 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-02 19:07 UTC by Brandon Squizzato
Modified: 2019-02-11 14:02 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-11 14:02:26 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
bsquizza: automate_bug-


Attachments (Terms of Use)

Description Brandon Squizzato 2018-07-02 19:07:00 UTC
Description of problem:
Testing CFME 5.10.0.1

Using manageiq-smartstate-0.2.11

Ran SSA against a windows server VM deployed in azure stack. The software analysis step failed with this traceback:

[----] E, [2018-07-02T14:55:46.296482 #9723:42cf84] ERROR -- : Q-task_id([job_dispatcher]) MIQExtract.extract undefined local variable or method `fs' for #<MiqWin32::Software:0x000000000110b408>
[----] E, [2018-07-02T14:55:46.296802 #9723:42cf84] ERROR -- : Q-task_id([job_dispatcher]) MIQExtract.extract /opt/rh/cfme-gemset/gems/manageiq-smartstate-0.2.11/lib/metadata/util/win32/Win32Software.rb:129:in `registry_applications_app_paths'

My guess is this commit introduced the error: https://github.com/ManageIQ/manageiq-smartstate/commit/04fad5c61fb59e8ffba1c0ad6c1ca7aacda90826

Comment 2 Brandon Squizzato 2018-07-02 19:13:21 UTC
Well upon taking another look I guess the code called this method in a similar way before the commit, so I can't blame that commit anymore :)

Comment 3 Brandon Squizzato 2018-07-02 19:24:25 UTC
I think the commit at fault here is: https://github.com/ManageIQ/manageiq-smartstate/commit/274cafc2b9ff6287326c68455a5a57adad9bb42b#diff-db9e66f0013704ce581b0371506fdb8c

Assigning to Jerry to take a look

Comment 4 Rich Oliveri 2018-07-02 19:29:24 UTC
Hui should have more cycles than Jerry.

Hui, let me know if you can't get to this. Ask Jerry if you have any questions.

Comment 8 Hui Song 2018-07-03 20:36:32 UTC
*** Bug 1594149 has been marked as a duplicate of this bug. ***

Comment 9 CFME Bot 2018-07-09 15:27:50 UTC
New commit detected on ManageIQ/manageiq-smartstate/master:

https://github.com/ManageIQ/manageiq-smartstate/commit/d07c496b4019d1c71ba6c7bfbbbe3dafbeef983b
commit d07c496b4019d1c71ba6c7bfbbbe3dafbeef983b
Author:     hsong-rh <hsong@redhat.com>
AuthorDate: Tue Jul  3 16:06:43 2018 -0400
Commit:     hsong-rh <hsong@redhat.com>
CommitDate: Tue Jul  3 16:06:43 2018 -0400

    Fix to generate correct applications & patches info for windows scanning.

    https://bugzilla.redhat.com/show_bug.cgi?id=1597363

 lib/metadata/util/win32/Win32Software.rb | 17 +-
 1 file changed, 9 insertions(+), 8 deletions(-)

Comment 11 Rich Oliveri 2018-07-12 19:30:43 UTC
Released version 0.2.12 of manageiq-smartstate.

Comment 12 Mike Shriver 2019-01-15 20:04:06 UTC
Tested in CFME 5.10.0.31.20190108221820_a0968c8

Azure windows instances complete smartstate analysis, with no exceptions due to local var bugs in manageiq-smartstate.


Note You need to log in before you can comment on or make changes to this bug.