Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159729 - Default /etc/nsswitch.conf should not mention nisplus
Summary: Default /etc/nsswitch.conf should not mention nisplus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-06-07 15:18 UTC by Brian Long
Modified: 2008-10-01 20:40 UTC (History)
3 users (show)

Fixed In Version: RHBA-2005-678
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 16:40:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:678 qe-ready SHIPPED_LIVE glibc bug fix update 2005-10-05 04:00:00 UTC

Description Brian Long 2005-06-07 15:18:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
/etc/nsswitch.conf contains various comments mentioning nisplus; however, nisplus is not supported by Red Hat or the upstream glibc developers.  I would like to suggest the default nsswitch.conf be updated with fully-supported examples in the comments.

Version-Release number of selected component (if applicable):
glibc-2.3.4-2

How reproducible:
Always

Steps to Reproduce:
1. cat /etc/nsswitch.conf
2.
3.
  

Actual Results:  # Legal entries are:
#
#       nisplus or nis+         Use NIS+ (NIS version 3)
<snip>
# Example:
#passwd:    db files nisplus nis
#shadow:    db files nisplus nis
#group:     db files nisplus nis
<snip>
# Example - obey only what nisplus tells us...
#services:   nisplus [NOTFOUND=return] files
#networks:   nisplus [NOTFOUND=return] files
#protocols:  nisplus [NOTFOUND=return] files
#rpc:        nisplus [NOTFOUND=return] files
#ethers:     nisplus [NOTFOUND=return] files
#netmasks:   nisplus [NOTFOUND=return] files


Expected Results:  nisplus should be removed or replaced with nis since it's supported by Red Hat.

Additional info:

I'm trying to make it clear for end users that nisplus is not supported.  Having examples mentioning nisplus is confusing for end users.

Comment 1 Joshua Jensen 2005-06-07 15:26:59 UTC
I had a bug open like this for years, not sure what happened to it.  nisplus
isn't supported, and having it listed *does* take some cycles in the ns resolve
process

It is slower, it doesn't work with what Red Hat ships, and it isn't supported
anyway.... why is it still mentioned there?

This is also a problem in RHEL3

Comment 3 Jakub Jelinek 2005-07-06 17:25:35 UTC
RHEL4 U2 initial glibc testing RPMs that should address also this problem
uploaded to ftp://people.redhat.com/jakub/glibc/2.3.4-2.10/


Comment 7 Red Hat Bugzilla 2005-10-05 16:40:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-678.html



Note You need to log in before you can comment on or make changes to this bug.