Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159725 - Copy and paste into app on VNC doesn't work
Summary: Copy and paste into app on VNC doesn't work
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 14:48 UTC by Nils Philippsen
Modified: 2018-04-11 11:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-20 16:47:00 UTC


Attachments (Terms of Use)

Description Nils Philippsen 2005-06-07 14:48:28 UTC
Description of problem:

Cutting/Copying and pasting out of (local) firefox into (remote) applications
inside a VNC viewer doesn't work.

Version-Release number of selected component (if applicable):

firefox-1.0.4-4
vnc-4.1.1-10

How reproducible:

Easy.

Steps to Reproduce:
1. Copy (left button select, optionally Ctrl+C) a text from a locally running
Firefox (web page or location entry doesn't matter)
2. Paste (middle button paste or Ctrl+V) into remote application inside a
running vncviewer
  
Actual results:
Pastes some old copy buffer instead of what was selected in Firefox

Expected results:
Pastes what I selected

Additional info:
Pasting into local terminal, then copying and pasting from there works.

Comment 1 Warren Togami 2005-09-30 19:48:00 UTC
Isn't remote clipboard broken for all other applications too, and not just firefox?

Comment 2 Nils Philippsen 2005-10-07 11:29:38 UTC
No, I just cut from a local gnome-terminal into a remote xterm (with vncconfig
running on the VNC display and appropriate settings of course).

Comment 3 Matěj Cepl 2007-12-20 16:47:00 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.