Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597221 - [RFE] Embedded Ansible: Create service item: not available for restricted user
Summary: [RFE] Embedded Ansible: Create service item: not available for restricted user
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: GA
: 5.10.0
Assignee: Zita Nemeckova
QA Contact: Ruslana Babyuk
URL:
Whiteboard: ui:tag
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-02 09:44 UTC by Ruslana Babyuk
Modified: 2018-07-23 19:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-23 19:41:41 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Ruslana Babyuk 2018-07-02 09:44:31 UTC
Description of problem:
Embedded Ansible: Create service item: not available for restricted user

Version-Release number of selected component (if applicable):
5.9

How reproducible:
100%

Steps to Reproduce:
1. Enable embedded ansible 
2. Create a restricted user(restriction with tag)
3. navigate to Ansible-> Repository
4. Add new repository
5. Add tag(step 2) for repository
6. As restricted user create Embedded Ansible service item

Actual results:
service item cannot be created by the restricted user

Expected results:
The user should be able to create service item

Additional info:

Comment 2 Zita Nemeckova 2018-07-09 12:21:36 UTC
Hi Ruslana,

does the restricted user has rights to the repository and Embedded Ansible provider via tags?

Thank,
Zita

Comment 4 Ruslana Babyuk 2018-07-10 07:50:31 UTC
I think you are right Zita, as the same behaviour we have for all other providers.
I'll change status to works for me then.

Thanks

Comment 5 bascar 2018-07-23 19:41:41 UTC
Per comment 4, not a bug but working as designed.


Note You need to log in before you can comment on or make changes to this bug.