Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159706 - bad management of SYSFONTACM in /sbin/setsysfont
Summary: bad management of SYSFONTACM in /sbin/setsysfont
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL: http://download.fedora.redhat.com/pub...
Whiteboard:
: 159704 159705 166113 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 09:52 UTC by Yves L'ECUYER
Modified: 2014-03-17 02:54 UTC (History)
2 users (show)

Fixed In Version: 8.12-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-07 16:53:28 UTC


Attachments (Terms of Use)

Description Yves L'ECUYER 2005-06-07 09:52:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; fr-FR; rv:1.7.7) Gecko/20050504 Fedora/1.7.7-3

Description of problem:
the SYSFONTACM option is not processed because of the following BUGGY lines in
/sbin/setsysfont:
------------------------
  if [ -n "$SYSFONTACM" ]; then
    if [ ! -f /lib/kbd/consoletrans/$SYSFONTACM_to_uni.trans ]; then
        SYSFONTACM=`echo $SYSFONTACM | sed "s|iso0|8859-|g;s|iso|8859-|g"`
    fi
    ARGS="$ARGS -m $SYSFONTACM"
  fi


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.using SYSFONTACM environment variable in /etc/sysconfig/i18n 
2.
3.
  

Actual Results:  BUGGY lines in
/sbin/setsysfont:
------------------------
  if [ -n "$SYSFONTACM" ]; then
    if [ ! -f /lib/kbd/consoletrans/$SYSFONTACM_to_uni.trans ]; then
        SYSFONTACM=`echo $SYSFONTACM | sed "s|iso0|8859-|g;s|iso|8859-|g"`
    fi
    ARGS="$ARGS -m $SYSFONTACM"
  fi


Expected Results:  in order to process correctly SYSFONTACM,the correct syntax must be:
  if [ -n "$SYSFONTACM" ]; then
    if [ ! -f /lib/kbd/consoletrans/${SYSFONTACM}_to_uni.trans ]; then
        SYSFONTACM=`echo $SYSFONTACM | sed "s/iso0/8859-/g;s/iso/8859-/g"`
    fi
    ARGS="$ARGS -m $SYSFONTACM"
  fi


Additional info:

THIS IS AVERY OLD BUGG existing even in RH9.
When you want a correct exchange between Window French version and Linux 
(with french accentuated characters in file name) 
 is a basic test too see if Windows <--> Unix are using the same code set) 

--> either in local environment (mounting local vfat partition with or without option:,codepage=850,iocharset=iso8859-1 )
--> or in SAMBA sharing
IT's MANDATORY TO SET i18n with
LANG=fr_FR
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

ALL other combination, and particularily the default one:
LANG="fr_FR.UTF-8"
SYSFONT="latarcyrheb-sun16"
doesn't work for a correct dialogue with French version of windows

While with the 3 lines above, its working, and all messages in linux console (tty1 to tty6) and in X/Windows environment are also shown correctly (at least in all the applications I have tested, OpenOffice included !)

Comment 1 Miloslav Trmač 2005-06-07 11:30:36 UTC
*** Bug 159704 has been marked as a duplicate of this bug. ***

Comment 2 Miloslav Trmač 2005-06-07 11:30:43 UTC
*** Bug 159705 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2005-06-07 16:53:28 UTC
Added, will be in 8.12-1.

Comment 4 Bill Nottingham 2005-08-19 07:05:50 UTC
*** Bug 166113 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.