Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596995 - DNF version 3.0.1 can't install / remove any program.
Summary: DNF version 3.0.1 can't install / remove any program.
Keywords:
Status: CLOSED DUPLICATE of bug 1596540
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-01 10:12 UTC by Yi-Jyun Pan
Modified: 2018-07-02 11:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-02 11:27:49 UTC


Attachments (Terms of Use)

Description Yi-Jyun Pan 2018-07-01 10:12:03 UTC
Description of problem:
When I update to the latest DNF version (3.0.1),
it can't work correctly.

Version-Release number of selected component (if applicable):
$ dnf --version
  Installed: dnf-0:3.0.1-1.fc29.noarch at 西元2018年07月01日 (週日) 08時36分08秒
  Built    : Fedora Project at 西元2018年06月26日 (週二) 16時02分50秒

  Installed: rpm-0:4.14.2-0.rc1.1.fc29.x86_64 at 西元2018年07月01日 (週日) 08時27分14秒
  Built    : Fedora Project at 西元2018年06月29日 (週五) 12時50分36秒


How reproducible:
$ sudo dnf install any-of-program
$ sudo dnf remove any-of-program
$ sudo dnf update

Steps to Reproduce:
1. Input 'sudo dnf install nano'
2. Wait a moment.

Actual results:
$ sudo dnf install nano
上次中介資料過期檢查:2:08:40 以前,時間點為 西元2018年07月01日 (週日) 16時02分19秒。
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 123, in cli_run
    ret = resolving(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 146, in resolving
    base.resolve(cli.demands.allow_erasing)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 817, in resolve
    self._transaction = self._goal2transaction(goal)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 725, in _goal2transaction
    ts.add_install(pkg, obs, reason)
  File "/usr/lib/python3.6/site-packages/dnf/db/group.py", line 256, in add_install
    ti_new = self.new(new, libdnf.transaction.TransactionItemAction_INSTALL, reason)
  File "/usr/lib/python3.6/site-packages/dnf/db/group.py", line 219, in new
    rpm_item = self._pkg_to_swdb_rpm_item(pkg)
  File "/usr/lib/python3.6/site-packages/dnf/db/group.py", line 210, in _pkg_to_swdb_rpm_item
    rpm_item = self.history.swdb.createRPMItem()
  File "/usr/lib/python3.6/site-packages/dnf/db/history.py", line 290, in swdb
    self._swdb = libdnf.transaction.Swdb(self.dbpath)
  File "/usr/lib64/python3.6/site-packages/libdnf/transaction.py", line 713, in __init__
    this = _transaction.new_Swdb(*args)
RuntimeError: C++ std::exception: Exec failed: no such table: main.trans_cmdline

Expected results:
Show the install details.

Additional info:

Comment 1 Martin Hatina 2018-07-02 11:27:49 UTC

*** This bug has been marked as a duplicate of bug 1596540 ***


Note You need to log in before you can comment on or make changes to this bug.