Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159699 - yum upgrade interrupted by rpm -e
Summary: yum upgrade interrupted by rpm -e
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 07:42 UTC by Jens Petersen
Modified: 2014-01-21 22:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 19:27:34 UTC


Attachments (Terms of Use)

Description Jens Petersen 2005-06-07 07:42:24 UTC
Description of problem:
When upgrading from FC3 to FC4 with yum, I "accidently" tried
to remove an unneeded package at the same time with "rpm -e".
This resulted in yum's updating of packages to terminate leaving
the rpmdb in an very consistent state.  I guess sets up the
rpm db transaction first before upgrading the packages.

Steps to Reproduce:
1. install FC3
2. install fedora-release of fc4
3. yum upgrade
4. while that is updating packages run "rpm -e".
  
Actual results:
Yum aborted updating, leaving rpmdb with fc4 pkg data
but only about half the packages actually upgraded. :-(

Expected results:
rpm -e to wait for lock on rpmdb to be freed.

Additional info:
Cleaning up after this is not fun... ;-)
(Yes, I know, I will use anaconda next, honest!)

Comment 1 Seth Vidal 2005-06-16 05:04:04 UTC
Sorry I haven't commented on this - but I don't think this is a yum bug.

it seems more like an rpm bug.

on the yum side I've done some thinking about how to fix the problem of being
halfway done with a transaction and how to complete it but it's not going to
happen tomorrow.

I guess I'll refile this under rpm.

Comment 2 Jeff Johnson 2005-07-13 08:54:23 UTC
Yum aborted and left a partially installed transaction, and it's yum, not rpm, where the fix needs to 
happen.

I guess I'll send the problem back to yum where the fix is needed.

Comment 3 Paul Nasrat 2005-07-29 19:03:19 UTC
Shouldn't there have been a transaction lock and the rpm -e wait for lock
(waiting for transaction lock)

Comment 4 Jens Petersen 2005-07-31 06:43:15 UTC
I wish...

Comment 5 Jeremy Katz 2005-09-21 19:27:34 UTC
Doing something like this isn't really supported due to problems like this which
can occur


Note You need to log in before you can comment on or make changes to this bug.