Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596912 - npm fails with "Error: cannot find module 'are-we-there-yet'
Summary: npm fails with "Error: cannot find module 'are-we-there-yet'
Keywords:
Status: CLOSED DUPLICATE of bug 1594647
Alias: None
Product: Fedora
Classification: Fedora
Component: npm
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-30 04:50 UTC by jman012345
Modified: 2018-07-06 17:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-06 17:24:13 UTC


Attachments (Terms of Use)

Description jman012345 2018-06-30 04:50:17 UTC
Description of problem:
npm fails to install any packages. Reinstallation of npm and nodejs do not fix the problem.

Version-Release number of selected component (if applicable):
Version      : 6.1.0
Release      : 1.10.5.0.1.fc29

How reproducible:
Always (on my system)

Steps to Reproduce:
1. sudo dnf install npm
2. npm i gitbook -g
3.

Actual results:
internal/modules/cjs/loader.js:596
    throw err;
    ^

Error: Cannot find module 'are-we-there-yet'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:594:15)
    at Function.Module._load (internal/modules/cjs/loader.js:520:25)
    at Module.require (internal/modules/cjs/loader.js:650:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.<anonymous> (/usr/lib/node/.bundled/npm/npmlog/log.js:2:16)
    at Module._compile (internal/modules/cjs/loader.js:702:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:713:10)
    at Module.load (internal/modules/cjs/loader.js:612:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:551:12)
    at Function.Module._load (internal/modules/cjs/loader.js:543:3)

Expected results:
Successful installation

Additional info:
The module "are-we-there-yet" exists on my system in /usr/lib/node_modules/npm/node_modules. I've tried adding this directory to my PATH and I get the same result trying to use npm.

Comment 1 Stephen Gallagher 2018-07-06 17:24:13 UTC

*** This bug has been marked as a duplicate of bug 1594647 ***


Note You need to log in before you can comment on or make changes to this bug.