Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159687 - installer crashes when root is on RAID device
Summary: installer crashes when root is on RAID device
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 00:06 UTC by Craig James
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-08 23:06:14 UTC


Attachments (Terms of Use)

Description Craig James 2005-06-07 00:06:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
When attempting to install with / on a RAID device, the installer got an exception, crashed, and rebooted.

Exception exceptions.KeyError:0 in <bound bethod RAIDDEVICE.__del__ of <fssetAIDDevice instance at 0xb74d484c>> ignored

The configuration was:

1. Two identical Seagate 80 GB disks
2. /boot was a 100 MB partition on /dev/hda1
3. /tmp was a 100 MB partition on /dev/hdc1
4. Both disks had a 150 MB partition on /dev/hd[ac]2
5. Rest of both disks (about 79 GB) were a software RAID 1 partition
   set up using the installer as /dev/md0

The partitioning and formatting went well, and files were written to the /boot partition, but when it started on the / partition it crashed the installer. 

Version-Release number of selected component (if applicable):
FC3 installation CD's

How reproducible:
Always

Steps to Reproduce:
1. See above
 

Actual Results:  The installer crashed

Expected Results:  It should have installed Linux on the / RAID 1 partition.

Additional info:

I was never able to get this to work.  Instead I bought a third disk, installed Linux on that, then used mdadm to create a RAID 1 disk with the original two disks.

Comment 1 Jeremy Katz 2005-06-07 20:01:28 UTC
Can you provide the full traceback?  

Comment 2 Craig James 2005-06-08 15:46:42 UTC
Unfortunately I can't - the installer crashed and rebooted.  Since there was no
file system, there were no files left behind.  (Plus I ran it again, which
reformatted the disks.)  Sorry.


Note You need to log in before you can comment on or make changes to this bug.