Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159686 - Installer crashes using fixed IP address with tulip0 / lite-on 82c168 PNIC
Summary: Installer crashes using fixed IP address with tulip0 / lite-on 82c168 PNIC
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-06 23:47 UTC by Craig James
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-07 20:01:15 UTC


Attachments (Terms of Use)

Description Craig James 2005-06-06 23:47:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
The FC3 installer crashed repeatedly with the message, when I specified a fixed IP address, netmask and gateway, on a machine with a "tulip0 / lite-on 82c168 PNIC" (from dmesg) on eth0.

/usr/lib/anaconda/iw/network_gui.py: 265: GtkWarning: file gtktable.c: line 515 (gtk_table_resize): assertion `nrows > 0 && nrows < 65535' failed
devTable = gtkTable(len/devopts, 2)
install exited abnormally

This happened 6 times in a row.  I tried many combinations; here's what finally cured the problem: 
  1. Installed a different network card
  2. Told it to ignore eth0 and use eth1 (eth0 is on the motherboard)
  2. Left the configuration on DNS (which I changed to a fixed IP after
     the installer finished).


Version-Release number of selected component (if applicable):
Fedora Core 3 installation CD's

How reproducible:
Always

Steps to Reproduce:
1. See above description
 

Actual Results:  Installer crashed and rebooted

Expected Results:  It should have installed FC3

Additional info:

Linux 2.6.11-1.27
Motherboard: MSI KM4AM
MSI manual says ethernet is "VIA VT6103 LAN controller"
Crash happened using:
    IP:  192.168.0.3
  Mask:  255.255.255.0
  Gate:  192.168.0.1

I don't know if it was the second network card, or switching to DNS, that made the installation finally succeed since I did both at once.  Sorry I couldn't go back to experiment - I needed the computer working.

Comment 1 Jeremy Katz 2005-06-07 20:01:15 UTC
This is fixed for FC4


Note You need to log in before you can comment on or make changes to this bug.