Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159684 - rpm looks for /usr/lib/rpm/ia32e-linux instead of /usr/lib/rpm/x86_64
Summary: rpm looks for /usr/lib/rpm/ia32e-linux instead of /usr/lib/rpm/x86_64
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-06 22:39 UTC by Paul Raines
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-06 16:22:23 UTC


Attachments (Terms of Use)

Description Paul Raines 2005-06-06 22:39:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Red Hat/1.0.3-1.4.1.centos4 Firefox/1.0.3

Description of problem:
When the x86_64 release of RHEL4 is installed on an Opteron box, all is fine.
rpmbuild looks for macros under /usr/lib/rpm/x86_64-linux/macros

# rpmbuild --showrc | grep ^macrofiles
macrofiles            : /usr/lib/rpm/macros:/usr/lib/rpm/x86_64-linux/macros:/etc/rpm/macros.*:/etc/rpm/macros:/etc/rpm/x86_64-linux/macros:~/.rpmmacros


However, when installed on a Xeon EM64T box, rpm looks in the wrong place
# rpmbuild --showrc | grep ^macrofiles
macrofiles            : /usr/lib/rpm/macros:/usr/lib/rpm/ia32e-linux/macros:/etc/rpm/macros.*:/etc/rpm/macros:/etc/rpm/ia32e-linux/macros:~/.rpmmacros


/usr/lib/rpm/ia32e-linux/macros does not exist and if someone uses rpmbuild
things like %_sysconfdir will be /usr/etc instead of /etc since the macros
in /usr/lib/rpm/macros are not overridden





Version-Release number of selected component (if applicable):
rpm-4.3.3-7_nonptl

How reproducible:
Always

Steps to Reproduce:
1. install x86_64 release of RHEL4 on a Xeon EM64T box
2. use rpmbuild

  

Actual Results:  %_sysconfdir was set to /usr/etc

Expected Results:  %_sysconfdir was set to /etc

Additional info:

Workaround is to do:  ln -s x86_64-linux /usr/lib/rpm/ia32e-linux

Comment 1 Jeff Johnson 2006-01-06 16:22:23 UTC
For rpm configuration purposes, the arch name is "x86_64", not "ia32e".

Either create the symlink
    ln -s x86_64-linux /usr/lib/rpm/ia32e-linux
or change the arch in /etc/rpm/platform.


Note You need to log in before you can comment on or make changes to this bug.