Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159676 - ImageMagick install/update fails -- libgs dependency
Summary: ImageMagick install/update fails -- libgs dependency
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-06 21:27 UTC by Jonathan S. Shapiro
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-30 23:20:01 UTC


Attachments (Terms of Use)

Description Jonathan S. Shapiro 2005-06-06 21:27:37 UTC
ImageMagic.i386 version 6.2.2.0-2 fails to install/upgrade because it relies on
libgs.so.7, which has been supersceded in ghostscript version 8 by libgs.so.8.
This means that the current development tree doesn't update cleanly.

This is high priority because ghostscript and ImageMagick are likely to be
installed simultaneously in ordinary installs of FC4, and the install will fail
in this case because of RPM dependency conflicts.

This class of bug has happened multiple times in the FC4test cycles. I want to
suggest that a new step needs to be integrated into the RPM update push cycle,
and I'm not sure where to file that RFE. The test is that there should be a
machine somewhere that has *everything* installed, and before the internal
bundle of updates is pushed somebody should run a "yum update" on that machine
to check for upgrade conflicts. We've had a couple of cases where updates were
stalled for several days by this class of error (last time it was the OpenOffice
build), and it's completely unnecessary.

Comment 1 Matthias Clasen 2005-09-30 23:20:01 UTC
Hmm, I still see ghostscript 7 in FC4. ghostscript 8 is in Rawhide, but there
the problem is fixed since ImageMagick has been rebuilt against it.


Note You need to log in before you can comment on or make changes to this bug.