Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596729 - old boincmgr notices are sometimes duplicated and flagged as new notices
Summary: old boincmgr notices are sometimes duplicated and flagged as new notices
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: boinc-client
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Laurence Field
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-29 14:42 UTC by Don Swaner
Modified: 2018-09-24 14:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-24 14:58:48 UTC


Attachments (Terms of Use)

Description Don Swaner 2018-06-29 14:42:26 UTC
Description of problem:
Sometimes, when boincmgr is started, it shows new Notices are available.  However, viewing the notices shows that the old existing notices have just been duplicated, and that there aren't any new notices.  Other times that boincmgr is started, this does not happen (viewing Notices shows only the unduplicated old notices, with no indication of available new notices).

Version-Release number of selected component (if applicable):
boinc-manager-7.10.2-1.fc28.x86_64

How reproducible:
Perhaps 5% of the time.

Steps to Reproduce:
1.  Start boincmgr
2.  Observe if any new notices are indicated (for example "Notices (5)").
3.  If there are new notices, check and see if they are only duplicated old notices.

Actual results:
Sometimes old notices are duplicated and flagged as new.

Expected results:
Old notices are not duplicated and are not flagged as new notices.

Additional info:
I frequently login and logout of the gnome desktop, starting boincmgr after logging in (autostart) and explicitly quitting boincmgr before logging out.

Comment 1 Germano Massullo 2018-09-24 13:33:45 UTC
Hi, have you tried to report this problem to upstream developers?
It may not be Fedora related

Comment 2 Don Swaner 2018-09-24 14:32:35 UTC
I have not reported the problem upstream.  For me the problem has almost completely gone away.  During the 3 week period from 7/5-7/28, the problem was occurring about 5% of the time.  And it just occurred once a few days ago, but that is the first time in about a month or more.  Recently I haven't been regularly logging in to the IBM World Community Grid website like I was previously - but that may be irrelevant.


Note You need to log in before you can comment on or make changes to this bug.