Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159649 - Default cvs server configuration does not work with SELinux
Summary: Default cvs server configuration does not work with SELinux
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cvs
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-06 15:47 UTC by Wayne Johnson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-30 09:34:03 UTC


Attachments (Terms of Use)

Description Wayne Johnson 2005-06-06 15:47:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When the cvs RPM is installed, it creates a default location for the cvs server repository.  This repository does not have the proper SELinux credentials for the cvs server to be able to access it.

cvs credentials:
-rwxr-xr-x  root     root     system_u:object_r:cvs_exec_t     /usr/bin/cvs

/var/cvs credentials:
drwxr-xr-x  root     root     system_u:object_r:var_t          /var/cvs

(this is my first time testing pre-release software, so forgive me if I'm not doing this properly).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install cvs rpm
2. Attempt to create files via cvs pserver:
cvs -d:pserver:waynej@localhost:/var/cvs import config xxx yyy

  

Actual Results:  cvs [import aborted]: unrecognized auth response from localhost: cvs pserver: cannot open /var/cvs/CVSROOT/config: Permission denied


Additional info:

Comment 1 Martin Stransky 2006-03-30 09:34:03 UTC
It's because you need to add user who has rights to access to the default CVS
repository (/var/cvs) and create apropriate selinux-rights. I think we can't
have a default user who can access to whole repository out-of-the-box...


Note You need to log in before you can comment on or make changes to this bug.