Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596455 - no filter named lib_utils_oo_dict_to_list_of_dict when uninstall glusterfs
Summary: no filter named lib_utils_oo_dict_to_list_of_dict when uninstall glusterfs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.7.z
Assignee: Scott Dodson
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-29 03:34 UTC by Anping Li
Modified: 2018-07-24 04:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A fix backported from the 3.9 installer incorrectly made use of lib_utils_oo_dict_to_list_of_dict which does not exist in the 3.7 codebase. This task has been updated to use the correct oo_dict_to_list_of_dict filter instead.
Clone Of:
Environment:
Last Closed: 2018-07-24 04:28:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2234 None None None 2018-07-24 04:28:38 UTC

Description Anping Li 2018-06-29 03:34:28 UTC
Description of problem:
uninstall glusterfs report  FAILED! => {"failed": true, "msg": "template error while templating string: no filter named 'lib_utils_oo_dict_to_list_of_dict'. String: {{ glusterfs_nodeselector | lib_utils_oo_dict_to_list_of_dict }}"}



Version-Release number of the following components:
openshift-ansible:v3.7.55

How reproducible:
always

Steps to Reproduce:
1. Deploy glusterfs on OCP
2. Uninstall glusterfs
ansible-playbook -i hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-glusterfs/uninstall.yml

Actual results:
TASK [openshift_storage_glusterfs : Delete pre-existing GlusterFS resources] ***
changed: [qe-37master-etcd-1.0628-a6m.qe.rhcloud.com] => (item={u'kind': u'template', u'name': u'glusterfs'})
changed: [qe-37master-etcd-1.0628-a6m.qe.rhcloud.com] => (item={u'kind': u'daemonset', u'name': u'glusterfs-storage'})
changed: [qe-37master-etcd-1.0628-a6m.qe.rhcloud.com] => (item={u'kind': u'storageclass', u'name': u'glusterfs-storage'})

TASK [openshift_storage_glusterfs : Unlabel any existing GlusterFS nodes] ******
fatal: [qe-37master-etcd-1.0628-a6m.qe.rhcloud.com]: FAILED! => {"failed": true, "msg": "template error while templating string: no filter named 'lib_utils_oo_dict_to_list_of_dict'. String: {{ glusterfs_nodeselector | lib_utils_oo_dict_to_list_of_dict }}"}

PLAY RECAP *********************************************************************


Expected results:

Comment 3 Wenkai Shi 2018-07-11 09:00:35 UTC
Verified with version openshift-ansible-3.7.57-1.git.33.cf01e48.el7, uninstall can succeed without any error.

# oc get po -n glusterfs 
NAME                                          READY     STATUS    RESTARTS   AGE
glusterblock-storage-provisioner-dc-1-nlw2b   1/1       Running   0          4h
glusterfs-storage-crgdx                       1/1       Running   0          4h
glusterfs-storage-dkzwx                       1/1       Running   0          4h
glusterfs-storage-kp88r                       1/1       Running   0          4h
heketi-storage-1-q444v                        1/1       Running   0          4h

# ansible-playbook -i inventory -vv /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-glusterfs/uninstall.yml
...
INSTALLER STATUS *****************************************************************************************************************************************************************************
Initialization             : Complete

# oc get po -n glusterfs 
No resources found.

Comment 5 errata-xmlrpc 2018-07-24 04:28:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2234


Note You need to log in before you can comment on or make changes to this bug.