Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159637 - local variable used before set
Summary: local variable used before set
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: magma-plugins
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-06 13:31 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-777
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-07 16:44:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:777 normal SHIPPED_LIVE magma-plugins bug fix update 2005-10-07 04:00:00 UTC

Description David Binderman 2005-06-06 13:31:16 UTC
Description of problem:

I just tried to compile package magma-plugins-1.0-0.pre18.3 from Redhat
Fedora Core development tree with the most excellent Intel C compiler.

The compiler said

sm.c(412): remark #592: variable "ret" is used before its value is set

The source code is

        return ret;

Clearly broken code. Suggest initialise local variable "ret" before first 
use.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Lon Hohberger 2005-07-20 15:53:36 UTC
How about removing it entirely, since it's never used except in the return
statement?

Comment 2 Lon Hohberger 2005-07-28 21:26:22 UTC
Fix in CVS as of 7/20

Comment 3 Red Hat Bugzilla 2005-10-07 16:44:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-777.html



Note You need to log in before you can comment on or make changes to this bug.