Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159632 - RewriteRule causes segmentation fault
Summary: RewriteRule causes segmentation fault
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-06 12:47 UTC by Carlo de Wolf
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:01:00 UTC


Attachments (Terms of Use)
A config file to create core dumps (doesn't work though) (deleted)
2005-06-06 13:58 UTC, Carlo de Wolf
no flags Details

Description Carlo de Wolf 2005-06-06 12:47:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412

Description of problem:
The following bit of configuration worked in 2.0.46-44.ent, but causes a segmentation fault in 
2.0.46-46.ent when a user requests either http://host/jira/ or https://host/jira/.

<Location "/jira">
        JkUriSet channel.socket ajp13
        RewriteEngine On
        RewriteCond %{SERVER_PORT} !^443$
        RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [R]
</Location>


Version-Release number of selected component (if applicable):
httpd-2.0.46-46.ent

How reproducible:
Always

Steps to Reproduce:
1. Create a configuration similar to the above
2. lynx http://localhost/jira
3. Observe crashing apache

Actual Results:  (gdb) where
#0  0x0093f503 in strlen () from /lib/tls/libc.so.6
#1  0x002c068c in ?? () from /etc/httpd/modules/mod_rewrite.so
#2  0x00000000 in ?? ()


Expected Results:  redirect to https://localhost/jira

Additional info:

Comment 1 Joe Orton 2005-06-06 13:03:19 UTC
Thanks for the report.

I cannot reproduce the above issue in an identical configuration except without
any use of JkURISet.

- Can you reproduce this in a configuration without using JkURISet?
- What JK module are you using?
- Can you attach a bzip2'ed core dump file to this bug?  (add "CoreDumpDirectory
/tmp" to your httpd.conf to ensure httpd can dump core)



Comment 2 Carlo de Wolf 2005-06-06 13:58:21 UTC
Created attachment 115166 [details]
A config file to create core dumps (doesn't work though)

The config file attached should create a core, but doesn't. Even with ulimit -c
unlimit.
Another weird side effect: if I comment in the first RewriteEngine on, it all
works as expected. But if I try to incorporate this in the main configuration
it fails again.

Comment 3 RHEL Product and Program Management 2007-10-19 19:01:00 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.