Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596264 - Translations broken in migration plugin
Summary: Translations broken in migration plugin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.4
Assignee: Milan Zázrivec
QA Contact: Kedar Kulkarni
URL:
Whiteboard: v2v
Depends On:
Blocks: 1564236
TreeView+ depends on / blocked
 
Reported: 2018-06-28 13:41 UTC by Kedar Kulkarni
Modified: 2018-09-05 12:56 UTC (History)
9 users (show)

Fixed In Version: 5.9.4.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-05 12:56:10 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (deleted)
2018-06-28 13:41 UTC, Kedar Kulkarni
no flags Details

Description Kedar Kulkarni 2018-06-28 13:41:19 UTC
Created attachment 1455338 [details]
Screenshot

Description of problem:
When I changed the language to something else than english, I saw that text is still in English. See the screenshot. I did not check all other languages, but it will be important to check with different languages and make sure appropriate translations are there. Please check the attached screenshot. 

Version-Release number of selected component (if applicable):
 5.9.3.3.20180627151410_682cecf 

How reproducible:
100%

Steps to Reproduce:
1.Go to Administrator-> My Settings 
2.At Bottom right corner, change locale to other than english
3.navigate to compute-> Migration

Actual results:
Translations not present for migration page

Expected results:
Translations should be present and accurate for migration page

Additional info:

Comment 2 Milan Zázrivec 2018-06-28 13:50:25 UTC
https://github.com/ManageIQ/miq_v2v_ui_plugin/pull/440

Comment 6 CFME Bot 2018-07-19 14:02:24 UTC
New commit detected on ManageIQ/manageiq-ui-classic/gaprindashvili:

https://github.com/ManageIQ/manageiq-ui-classic/commit/99a8bcf36adfaba70993419348486b051e21be48
commit 99a8bcf36adfaba70993419348486b051e21be48
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Tue Jul 17 07:31:56 2018 -0400
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Tue Jul 17 07:31:56 2018 -0400

    Update .json gettext catalogs (javascript) for Gaprindashvili update

    https://bugzilla.redhat.com/show_bug.cgi?id=1596264

 app/assets/javascripts/locale/en/app.js | 2 +-
 app/assets/javascripts/locale/es/app.js | 2 +-
 app/assets/javascripts/locale/fr/app.js | 2 +-
 app/assets/javascripts/locale/ja/app.js | 2 +-
 app/assets/javascripts/locale/pt_BR/app.js | 2 +-
 app/assets/javascripts/locale/zh_CN/app.js | 2 +-
 6 files changed, 6 insertions(+), 6 deletions(-)

Comment 8 Kedar Kulkarni 2018-07-30 18:43:27 UTC
on 5.9.4.1 translations seems to be right.

Disclaimer: I can't read other languages, only verified that once I select language other than English, all the prompts and buttons are in selected language.


Note You need to log in before you can comment on or make changes to this bug.