Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159622 - 3 * return statement with no expression
Summary: 3 * return statement with no expression
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libglade-java
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-06 08:19 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-05 19:54:07 UTC


Attachments (Terms of Use)

Description David Binderman 2005-06-06 08:19:56 UTC
Description of problem:

I just tried to compile package libgnome-2.10.0-3 from Redhat
Fedora Core development tree with the usual GNU C compiler.

The compiler said

1.

src/jni/org_gnu_glade_LibGlade.c:149: warning: `return' with no value, in
function returning non-void

The source code is

    if (buf == NULL)
        return;

Clearly broken code. Suggest add expression to return statement.

2.

src/jni/org_gnu_glade_LibGlade.c:160: warning: `return' with no value, in
function returning non-void
src/jni/org_gnu_glade_LibGlade.c:191: warning: `return' with no value, in
function returning non-void

Duplicates.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Stepan Kasal 2007-11-05 19:54:07 UTC
I believe the problem has been fixed since the time it was reported.
Current Fedora contains libglade-java-2.15.5, and it is routinely built with the
current GNU C compiler.


Note You need to log in before you can comment on or make changes to this bug.