Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596150 - Update libsolv to expose repodata_dir2str, repodata_str2dir, repodata_add_dirstr in the Python binding
Summary: Update libsolv to expose repodata_dir2str, repodata_str2dir, repodata_add_dir...
Keywords:
Status: CLOSED DUPLICATE of bug 1596285
Alias: None
Product: Fedora
Classification: Fedora
Component: libsolv
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1596237 1596238 1596149
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-28 10:33 UTC by mkovacik
Modified: 2018-06-28 22:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1596149
Environment:
Last Closed: 2018-06-28 22:24:15 UTC


Attachments (Terms of Use)

Description mkovacik 2018-06-28 10:33:19 UTC
+++ This bug was initially created as a clone of Bug #1596149 +++

libsolv-0.6.34-1.fc27 doesn't expose the functions repodata_str2dir, repodata_dir2str and repodata_add_dirstr in its Python bindings[1] (python[2,3]-solv*.rpm), needed for proper file-related dependencies resolving.

The Pulp project will eventually adopt the libsolv library to perform dependency solving[2] and being able to integrate sooner than F29 will benefit the testing/adoption of libsolv in the Pulp project.

Thanks!
milan

[1] https://github.com/openSUSE/libsolv/commit/878337b8ae83c5e33ca589dcbe228b7a2210dd25
[2] https://github.com/pulp/pulp_rpm/pull/1122

Comment 1 Igor Gnatenko 2018-06-28 22:24:15 UTC

*** This bug has been marked as a duplicate of bug 1596285 ***


Note You need to log in before you can comment on or make changes to this bug.