Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596138 - [rpc.nfsd] Setting version failed: errno 22 (Invalid argument) since 1.3.0-0.55.el7
Summary: [rpc.nfsd] Setting version failed: errno 22 (Invalid argument) since 1.3.0-0....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.6
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
: 1614464 1615801 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-28 09:58 UTC by Yongcheng Yang
Modified: 2018-10-30 11:48 UTC (History)
14 users (show)

Fixed In Version: nfs-utils-1.3.0-0.59.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:48:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3311 None None None 2018-10-30 11:48:44 UTC

Description Yongcheng Yang 2018-06-28 09:58:50 UTC
Description of problem:
Looks like there's a problem introduced by Bug 1436977 (https://bugzilla.redhat.com/show_bug.cgi?id=1436977).
It emits warning when using the rpc.nfsd options -N or -V now, i.e.
rpc.nfsd: Setting version failed: errno 22 (Invalid argument)

Version-Release number of selected component (if applicable):
nfs-utils-1.3.0-0.55.el7
(It's good in 1.3.0-0.54.el7)

How reproducible:
always

Steps to Reproduce:
Using rpc.nfsd -N or --no-nfs-version vers
and
Using rpc.nfsd -V or --nfs-version vers

Actual results:
[root@ibm-x3650m4-08 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.55.el7.x86_64
[root@ibm-x3650m4-08 ~]# rpc.nfsd 0 && rpc.nfsd -N 3
rpc.nfsd: Setting version failed: errno 22 (Invalid argument)
[root@ibm-x3650m4-08 ~]# echo $?
0
[root@ibm-x3650m4-08 ~]# rpc.nfsd 0 && rpc.nfsd -N 4
rpc.nfsd: Setting version failed: errno 22 (Invalid argument)
[root@ibm-x3650m4-08 ~]# echo $?
0
[root@ibm-x3650m4-08 ~]# rpc.nfsd 0 && rpc.nfsd -V 4
rpc.nfsd: Setting version failed: errno 22 (Invalid argument)
[root@ibm-x3650m4-08 ~]# echo $?
0
[root@ibm-x3650m4-08 ~]# 


Expected results:
*No warning*
[root@ibm-x3550m4-02 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.54.el7.x86_64
[root@ibm-x3550m4-02 ~]# rpc.nfsd 0 && rpc.nfsd -N 3
[root@ibm-x3550m4-02 ~]# rpc.nfsd 0 && rpc.nfsd -V 4
[root@ibm-x3550m4-02 ~]#

Comment 2 Yongcheng Yang 2018-06-28 11:05:32 UTC
Turns out this warning can be easily reproduced without any argument:
~~~~~~~~~~~~~~~~~~~~~~~~
[root@ibm-x3650m4-08 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.55.el7.x86_64
                 ^^^^
[root@ibm-x3650m4-08 ~]# >/etc/sysconfig/nfs
[root@ibm-x3650m4-08 ~]# >/etc/nfs.conf
[root@ibm-x3650m4-08 ~]# systemctl start nfs && systemctl stop nfs
[root@ibm-x3650m4-08 ~]# rpc.nfsd 0
[root@ibm-x3650m4-08 ~]# rpc.nfsd
rpc.nfsd: Setting version failed: errno 22 (Invalid argument) <<<<<<<<
[root@ibm-x3650m4-08 ~]# rpcinfo -p | grep -w nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
[root@ibm-x3650m4-08 ~]# 

What's more, rpc.nfsd -N 3/4 or -V 3/4 won't work as expected:
~~~~~~~~~~~~~~~~~~~~~~~~
[root@ibm-x3650m4-08 ~]# rpc.nfsd 0 && rpc.nfsd -N 3
rpc.nfsd: Setting version failed: errno 22 (Invalid argument)
[root@ibm-x3650m4-08 ~]# rpcinfo -p | grep -w nfs
    100003    3   tcp   2049  nfs   <<<<<<<<<<<<
    100003    4   tcp   2049  nfs
    100003    3   udp   2049  nfs   <<<<<<<<<<<<
    100003    4   udp   2049  nfs
[root@ibm-x3650m4-08 ~]# rpc.nfsd 0 && rpc.nfsd -N 4
rpc.nfsd: Setting version failed: errno 22 (Invalid argument)
[root@ibm-x3650m4-08 ~]# rpcinfo -p | grep -w nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs   <<<<<<<<<<<<
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs   <<<<<<<<<<<<
[root@ibm-x3650m4-08 ~]# 

Compared with previous actions:
~~~~~~~~~~~~~~~~~~~~~~~~
[root@ibm-x3550m4-02 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.54.el7.x86_64
                 ^^^^
[root@ibm-x3550m4-02 ~]# rpc.nfsd 0 && rpc.nfsd -N 3
[root@ibm-x3550m4-02 ~]# rpcinfo -p | grep -w nfs
    100003    4   tcp   2049  nfs
    100003    4   udp   2049  nfs
[root@ibm-x3550m4-02 ~]# rpc.nfsd 0 && rpc.nfsd -N 4
[root@ibm-x3550m4-02 ~]# rpcinfo -p | grep -w nfs
    100003    3   tcp   2049  nfs
    100003    3   udp   2049  nfs
[root@ibm-x3550m4-02 ~]#

Comment 15 Zhi Li 2018-08-08 09:31:17 UTC
This issue also influences /etc/nfs.conf, my test result is listed as follow:

rhel-7.6
~~~~
[root@ ~]# uname -r
3.10.0-931.el7.x86_64
[root@ ~]# systemctl restart nfs
[root@ ~]# cat /proc/fs/nfsd/versions 
+2 +3 +4 +4.1 +4.2
[root@ ~]# cat >> /etc/nfs.conf 
[nfsd]
vers2=n
vers3=n
[root@ ~]# systemctl restart nfs
[root@hp-dl380pg8-10 ~]# cat /proc/fs/nfsd/versions 
+2 +3 +4 +4.1 +4.2

rhel-7.5
~~~~
[root@ ~]# uname -r
3.10.0-862.el7.x86_64
[root@ ~]# systemctl restart nfs
[root@ ~]# cat /proc/fs/nfsd/versions 
-2 +3 +4 +4.1 +4.2
[root@ ~]# cat >> /etc/nfs.conf 
[nfsd]
vers2=n
vers3=n
[root@ ~]# systemctl restart nfs
[root@hp-dl388g8-20 ~]# cat /proc/fs/nfsd/versions 
-2 -3 +4 +4.1 +4.2

Comment 18 Yongcheng Yang 2018-08-10 02:10:19 UTC
*** Bug 1614464 has been marked as a duplicate of this bug. ***

Comment 21 Yongcheng Yang 2018-08-14 11:57:10 UTC
*** Bug 1615801 has been marked as a duplicate of this bug. ***

Comment 22 Yongcheng Yang 2018-09-28 10:17:43 UTC
(As Bug 1614603 Comment #15 says) Have verified in nfs-utils-1.3.0-0.60.el7:
--------------------------------------------------
[10:28:49 root@ ~~]# rpc.nfsd
[10:28:49 root@ ~~]# rpcinfo -p | grep -w nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs

Compared with the previous nfs-utils-1.3.0-0.57.el7:
--------------------------------------------------
[23:22:30 root@ ~~]# rpc.nfsd
rpc.nfsd: Setting version failed: errno 22 (Invalid argument)
[23:22:30 root@ ~~]# rpcinfo -p | grep -w nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs


Moving to VERIFIED now. Thanks for the help!

Comment 24 errata-xmlrpc 2018-10-30 11:48:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3311


Note You need to log in before you can comment on or make changes to this bug.