Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159605 - With firewall enabled - sharing printer over IPP needs port 631 open
Summary: With firewall enabled - sharing printer over IPP needs port 631 open
Keywords:
Status: CLOSED DUPLICATE of bug 129129
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-05 17:48 UTC by Dwayne Bailey
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-06 16:10:30 UTC


Attachments (Terms of Use)

Description Dwayne Bailey 2005-06-05 17:48:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
It seems rather easy to share a printer using the GUI.  However if you also have the firewall enabled it will not by default open port 631 to allow incomming IPP requests.  This is non intuative for the average user.

From the client machines your print job head of happily and disappear into limbo with no report that they can't actually get to port 631 on the remote printer.

s-c-p should warn if the firewall is enabled with no open port 631 or allow the user to open that port for the specified users.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enable firewall with no additional ports open
2. Add a printer to cups and share it with all users
3. On a remote machine add the printer
4. From the remore machine print.  Wait forever :)
  

Actual Results:  Nothing happened on the remote printer

Expected Results:  You should be able to print

Additional info:

Comment 1 Sitsofe Wheeler 2005-06-05 22:01:11 UTC
I was going to say that I'd seen this one before but it turns out that the bugs
I was thinking of are all samba related.

It's not a million miles away from the other "firewall needs hooks so programs
can check if port is open" bugs like bug #129129 though.

Comment 2 Tim Waugh 2005-06-06 16:10:30 UTC

*** This bug has been marked as a duplicate of 129129 ***


Note You need to log in before you can comment on or make changes to this bug.