Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1596032 - Why does sudo package depend on vim-minimal?
Summary: Why does sudo package depend on vim-minimal?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sudo
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Daniel Kopeček
QA Contact: Martin Zelený
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-28 06:03 UTC by Matěj Cepl
Modified: 2018-10-30 11:09 UTC (History)
2 users (show)

Fixed In Version: sudo-1.8.23-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:09:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3199 None None None 2018-10-30 11:09:46 UTC

Description Matěj Cepl 2018-06-28 06:03:06 UTC
Description of problem:
 ~$ sudo yum remove vim-minimal
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, remove-with-leaves
Resolving Dependencies
--> Running transaction check
---> Package vim-minimal.x86_64 2:8.0.1813-1.0.97.el7.centos will be erased
--> Processing Dependency: vim-minimal for package: sudo-1.8.19p2-13.el7.x86_64
--> Processing Dependency: vim-minimal for package: cvs-1.11.23-35.el7.x86_64
--> Running transaction check
---> Package cvs.x86_64 0:1.11.23-35.el7 will be erased
--> Processing Dependency: cvs for package: git-cvs-2.18.0-1.el7.noarch
--> Processing Dependency: cvs for package: cvsps-2.2-0.14.b1.el7.x86_64
---> Package sudo.x86_64 0:1.8.19p2-13.el7 will be erased
--> Running transaction check
---> Package cvsps.x86_64 0:2.2-0.14.b1.el7 will be erased
---> Package git-cvs.noarch 0:2.18.0-1.el7 will be erased
--> Processing Dependency: /usr/bin/vi for package: 1:libguestfs-tools-c-1.36.10-6.el7_5.2.x86_64
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libguestfs-tools-c.x86_64 1:1.36.10-6.el7_5.2 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================================
 Package                                 Arch                        Version                                              Repository                                                Size
=========================================================================================================================================================================================
Removing:
 vim-minimal                             x86_64                      2:8.0.1813-1.0.97.el7.centos                         @mcepl-vim8                                              1.0 M
Removing for dependencies:
 cvs                                     x86_64                      1.11.23-35.el7                                       @rhel-nightly/7Workstation                               1.1 M
 cvsps                                   x86_64                      2.2-0.14.b1.el7                                      @rhel-nightly-optional/7Workstation                      116 k
 git-cvs                                 noarch                      2.18.0-1.el7                                         @group_git-maint-git                                     329 k
 libguestfs-tools-c                      x86_64                      1:1.36.10-6.el7_5.2                                  @updates                                                  17 M
 sudo                                    x86_64                      1.8.19p2-13.el7                                      @rhel-nightly/7Workstation                               3.9 M

Transaction Summary
=========================================================================================================================================================================================
Remove  1 Package (+5 Dependent packages)

Installed size: 23 M
Is this ok [y/N]: n
Exiting on user command
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2018-06-28.07-52.wc3pA5.yumtx
 ~$ 



Version-Release number of selected component (if applicable):
sudo-1.8.19p2-13.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. see above
2.
3.

Actual results:
see above

Expected results:
cvs should not depend on any particular implementation of $EDITOR. If I would like to replace vim on my system with neovim (or any other $EDITOR), why should sudo, stop me? If it requires some particular command (above $EDITOR), then it should require that file (e.g., /usr/bin/ex).

Comment 2 Daniel Kopeček 2018-06-28 09:49:51 UTC
(In reply to Matěj Cepl from comment #0)
> Description of problem:
>  ~$ sudo yum remove vim-minimal
> Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks,
> remove-with-leaves
> Resolving Dependencies
> --> Running transaction check
> ---> Package vim-minimal.x86_64 2:8.0.1813-1.0.97.el7.centos will be erased
> --> Processing Dependency: vim-minimal for package:
> sudo-1.8.19p2-13.el7.x86_64
> --> Processing Dependency: vim-minimal for package: cvs-1.11.23-35.el7.x86_64
> --> Running transaction check
> ---> Package cvs.x86_64 0:1.11.23-35.el7 will be erased
> --> Processing Dependency: cvs for package: git-cvs-2.18.0-1.el7.noarch
> --> Processing Dependency: cvs for package: cvsps-2.2-0.14.b1.el7.x86_64
> ---> Package sudo.x86_64 0:1.8.19p2-13.el7 will be erased
> --> Running transaction check
> ---> Package cvsps.x86_64 0:2.2-0.14.b1.el7 will be erased
> ---> Package git-cvs.noarch 0:2.18.0-1.el7 will be erased
> --> Processing Dependency: /usr/bin/vi for package:
> 1:libguestfs-tools-c-1.36.10-6.el7_5.2.x86_64
> --> Restarting Dependency Resolution with new changes.
> --> Running transaction check
> ---> Package libguestfs-tools-c.x86_64 1:1.36.10-6.el7_5.2 will be erased
> --> Finished Dependency Resolution
> 
> Dependencies Resolved
> 
> =============================================================================
> =============================================================================
> ===============================
>  Package                                 Arch                        Version
> Repository                                                Size
> =============================================================================
> =============================================================================
> ===============================
> Removing:
>  vim-minimal                             x86_64                     
> 2:8.0.1813-1.0.97.el7.centos                         @mcepl-vim8            
> 1.0 M
> Removing for dependencies:
>  cvs                                     x86_64                     
> 1.11.23-35.el7                                      
> @rhel-nightly/7Workstation                               1.1 M
>  cvsps                                   x86_64                     
> 2.2-0.14.b1.el7                                     
> @rhel-nightly-optional/7Workstation                      116 k
>  git-cvs                                 noarch                     
> 2.18.0-1.el7                                         @group_git-maint-git   
> 329 k
>  libguestfs-tools-c                      x86_64                     
> 1:1.36.10-6.el7_5.2                                  @updates               
> 17 M
>  sudo                                    x86_64                     
> 1.8.19p2-13.el7                                     
> @rhel-nightly/7Workstation                               3.9 M
> 
> Transaction Summary
> =============================================================================
> =============================================================================
> ===============================
> Remove  1 Package (+5 Dependent packages)
> 
> Installed size: 23 M
> Is this ok [y/N]: n
> Exiting on user command
> Your transaction was saved, rerun it with:
>  yum load-transaction /tmp/yum_save_tx.2018-06-28.07-52.wc3pA5.yumtx
>  ~$ 
> 
> 
> 
> Version-Release number of selected component (if applicable):
> sudo-1.8.19p2-13.el7.x86_64
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. see above
> 2.
> 3.
> 
> Actual results:
> see above
> 
> Expected results:
> cvs should not depend on any particular implementation of $EDITOR. If I
> would like to replace vim on my system with neovim (or any other $EDITOR),
> why should sudo, stop me? If it requires some particular command (above
> $EDITOR), then it should require that file (e.g., /usr/bin/ex).

sudo requires some editor (from a limited list of compatible editors) because of visudo.

I'm ok with changing the dependency from vim-minimal to /usr/bin/vi (this path is passed to sudo's ./configure at build-time).

In Fedora it was fixed such that the spec file contains "Recommends: vim-minimal" but the "Recommends:" feature is not available in RHEL 7.x.

@dalibor Are you ok with adding this BZ to the current (7.6) erratum?

Comment 8 errata-xmlrpc 2018-10-30 11:09:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3199


Note You need to log in before you can comment on or make changes to this bug.