Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159589 - Issues with se401 v4l driver
Summary: Issues with se401 v4l driver
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-05 09:18 UTC by Kars de Jong
Modified: 2015-01-04 22:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-25 07:56:18 UTC


Attachments (Terms of Use)

Description Kars de Jong 2005-06-05 09:18:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When connecting a Kensington USB webcam, the kernel complains about a missing release callback in the driver.

But, what is worse, when actually using it, it seems the driver calls a function which may sleep from interrupt context.

The camera does seem to work though.


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.27_FC3

How reproducible:
Always

Steps to Reproduce:
1. Plug in webcam
2. Start gnomemeeting (for instance)

  

Actual Results:  Lots of entries in the kernel log file.

Expected Results:  No entries in the kernel log file.

Additional info:

This is the message in the log after plugging the camera in:

drivers/usb/media/se401.c: SE401 usb camera driver version 0.24 registering
videodev: "Kensington VideoCAM 67016" has no release callback. Please fix your driver for proper sysfs support, see http://lwn.net/Articles/36850/

And this is the message that keeps being logged when the camera is in use:

Debug: sleeping function called from invalid context at mm/slab.c:2088
in_atomic():1, irqs_disabled():1
 [<c011bfbe>] __might_sleep+0x9c/0xa4
 [<c0154e85>] __kmalloc+0x7c/0x7e
 [<e098565d>] ohci_urb_enqueue+0x81/0x5be [ohci_hcd]
 [<c0119da0>] activate_task+0x56/0x65
 [<c02bf741>] hcd_submit_urb+0x1b5/0x304
 [<c011ab09>] __wake_up_common+0x35/0x55
 [<c02c059a>] usb_submit_urb+0x1bd/0x2bb
 [<e0adc5c5>] se401_video_irq+0x7d/0x1ff [se401]
 [<c02c0110>] usb_hcd_giveback_urb+0x17/0x49
 [<e0984175>] finish_urb+0xc6/0x2c2 [ohci_hcd]
 [<e09854d9>] finish_unlinks+0x245/0x284 [ohci_hcd]
 [<e09855cb>] dl_done_list+0xb3/0xc4 [ohci_hcd]
 [<e09868cb>] ohci_irq+0xed/0x361 [ohci_hcd]
 [<c010878f>] timer_interrupt+0x80/0x22e
 [<c02c0166>] usb_hcd_irq+0x24/0x57
 [<c0148640>] handle_IRQ_event+0x31/0x62
 [<c014872f>] __do_IRQ+0xbe/0x31f
 [<c010564f>] do_IRQ+0x4c/0x85
 =======================
 [<c0103a72>] common_interrupt+0x1a/0x20

Comment 1 Dave Jones 2005-07-15 19:40:44 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Kars de Jong 2005-08-27 13:14:06 UTC
Sorry, I no longer run Fedora, so I can't test this anymore.
However, with Debian (running kernel 2.6.8-2-k7) the "release callback" warning
is present there too, but not the other "sleeping function called from invalid
context at mm/slab.c:2088" warning.



Note You need to log in before you can comment on or make changes to this bug.