Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595785 - AVC: denied { map } access for comm="ldconfig" on number of modules.
Summary: AVC: denied { map } access for comm="ldconfig" on number of modules.
Keywords:
Status: CLOSED DUPLICATE of bug 1583084
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-27 14:31 UTC by Amith
Modified: 2018-07-10 17:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 15:02:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Amith 2018-06-27 14:31:01 UTC
Description of problem:
During the installation of RHEL-7.6 on a beaker VM, we have observed AVC denial error wherein "ldconfig" is being denied map access to a number of library modules like /usr/lib64/libfreebl3.so, /usr/lib64/libdevmapper-event.so.1.02, /usr/lib64/device-mapper/libdevmapper-event-lvm2snapshot.so, /usr/lib64/libdl-2.17.so etc. See the error below:

time->Tue Jun 26 14:15:29 2018
type=PROCTITLE msg=audit(1530002729.732:57): proctitle=6C64636F6E666967002D72002F7661722F746D702F6472616375742E684A656A64492F696E697472616D6673
type=SYSCALL msg=audit(1530002729.732:57): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=86ba0 a2=1 a3=1 items=0 ppid=2623 pid=9188 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ldconfig" exe="/usr/sbin/ldconfig" subj=system_u:system_r:ldconfig_t:s0 key=(null)
type=AVC msg=audit(1530002729.732:57): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libfreeblpriv3.so" dev="dm-0" ino=2675 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:58): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libfreebl3.so" dev="dm-0" ino=2677 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:59): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libdevmapper-event.so.1.02" dev="dm-0" ino=2682 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:60): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/device-mapper/libdevmapper-event-lvm2mirror.so" dev="dm-0" ino=9034 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:61): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/device-mapper/libdevmapper-event-lvm2raid.so" dev="dm-0" ino=9036 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:62): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/device-mapper/libdevmapper-event-lvm2snapshot.so" dev="dm-0" ino=9038 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:63): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/device-mapper/libdevmapper-event-lvm2thin.so" dev="dm-0" ino=9040 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:64): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libnss_files-2.17.so" dev="dm-0" ino=9048 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.732:65): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libnss_files-2.17.so" dev="dm-0" ino=9048 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:66): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libnss_files-2.17.so" dev="dm-0" ino=9048 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:67): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libtinfo.so.5.9" dev="dm-0" ino=2664 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:68): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libtinfo.so.5.9" dev="dm-0" ino=2664 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:69): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libdl-2.17.so" dev="dm-0" ino=10752 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:70): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libdl-2.17.so" dev="dm-0" ino=10752 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:71): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libdl-2.17.so" dev="dm-0" ino=10752 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:72): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libc-2.17.so" dev="dm-0" ino=10765 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:73): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libc-2.17.so" dev="dm-0" ino=10765 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:74): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libc.so" dev="dm-0" ino=10767 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:75): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/ld-2.17.so" dev="dm-0" ino=10768 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:76): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/ld-2.17.so" dev="dm-0" ino=10768 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.733:77): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/librt-2.17.so" dev="dm-0" ino=10770 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.737:133): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libsepol.so.1" dev="dm-0" ino=10831 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.737:134): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libaio.so.1.0.1" dev="dm-0" ino=10832 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.738:152): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/libdevmapper-event-lvm2.so.2.02" dev="dm-0" ino=10850 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file permissive=0
----

type=AVC msg=audit(1530002729.738:153): avc:  denied  { map } for  pid=9188 comm="ldconfig" path="/usr/lib64/liblvm2cmd.so.2.02" dev="dm-0" ino=10851 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:kdumpctl_tmp_t:s0 tclass=file 

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-204.el7.noarch

How reproducible:
Always

Steps to Reproduce:
See the failures in beaker tasks:
 - https://beaker.engineering.redhat.com/recipes/5312785#task74364959
 - https://beaker.engineering.redhat.com/recipes/5314329#task74391929

Actual results:


Expected results:


Additional info:

Comment 2 Lukas Vrabec 2018-06-27 15:02:09 UTC

*** This bug has been marked as a duplicate of bug 1583084 ***


Note You need to log in before you can comment on or make changes to this bug.