Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595779 - [wayland] text selection and graphical glitches on HiDPI display
Summary: [wayland] text selection and graphical glitches on HiDPI display
Keywords:
Status: CLOSED DUPLICATE of bug 1590388
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-27 14:23 UTC by Andrea Bolognani
Modified: 2018-08-06 11:16 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-06 11:16:29 UTC


Attachments (Terms of Use)
Graphical glitches on hover (deleted)
2018-06-27 14:23 UTC, Andrea Bolognani
no flags Details
Oversized suggestions (deleted)
2018-06-27 14:24 UTC, Andrea Bolognani
no flags Details

Description Andrea Bolognani 2018-06-27 14:23:51 UTC
Created attachment 1455059 [details]
Graphical glitches on hover

Description of problem:

  My laptop is connected to a 3200x1800 27" display and I'm running
  a pretty vanilla GNOME session on Wayland. I launched Firefox
  through the "Firefox on Wayland" application icon.

  Text selection is very wonky: if I select a few paragraphs, then
  click outside of the selection with the intent to cancel it, most
  of the time the selection looks like it wasn't canceled; similarly,
  if I select some text when a selection is already active, the
  previous selection might or might not look like it was canceled.

  In both cases, switching to another window and then back to Firefox
  reveals that the selection had been updated as expected, only the
  new status was not reflected on the screen until a full repaint had
  been forced.

  Performance for text selection is pretty bad, with it lagging
  visibly behind the cursor; text input is also laggy, both in the
  address bar and in the "find in page" input box.

  When searching for text inside a page, results are sometimes
  skipped over: eg. if a search result is highlighted and there are
  two more results down the page, pressing Enter the first time might
  not result in a screen update, while pressing it a second time
  might scroll all the way down to the third result; using
  Shift+Enter to search backwards might then work perfectly fine and
  show the second result, followed by the initial result. It's very
  inconsistent.

  There are other graphical glitches, such as background colors tied
  to :hover not updating properly as the mouse cursor moves around,
  or the suggestion box for the address bar being massively upscaled;
  screenshots of these latter issues, the easiest ones to show off in
  static images, are attached.

  None of the above seems to happen when I'm using the internal
  laptop panel (1920x1080) instead of the external monitor.

Version-Release number of selected components:

  firefox-60.0.2-1.fc28.x86_64
  libwayland-client-1.15.0-1.fc28.x86_64
  gnome-session-wayland-session-3.28.1-1.fc28.x86_64

Comment 1 Andrea Bolognani 2018-06-27 14:24:49 UTC
Created attachment 1455060 [details]
Oversized suggestions

Comment 2 Andrea Bolognani 2018-06-27 14:58:36 UTC
Sorry, the external monitor is actually running at 3840x2160.

Comment 3 Martin Stransky 2018-08-06 11:16:29 UTC
It's a dupe of Bug 1590388

*** This bug has been marked as a duplicate of bug 1590388 ***


Note You need to log in before you can comment on or make changes to this bug.