Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595772 - Nova computes disk space incorrectly when deployed with cinder volumes on NFS
Summary: Nova computes disk space incorrectly when deployed with cinder volumes on NFS
Keywords:
Status: NEW
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: nova-maint
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-27 14:14 UTC by Cody Swanson
Modified: 2019-04-12 05:13 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Cody Swanson 2018-06-27 14:14:04 UTC
Description of problem:

When scheduling instances with cinder boot volumes on NFS storage nova seems to incorrectly calculate compute storage and filter compute hosts out. I'm not sure why it's looking at local compute node ephemeral storage when the only storage configured for the instance is a boot from volume stored on NFS.

>nova hypervisor-stats
+----------------------+----------+
| Property | Value |
+----------------------+----------+
| count | 54 |
| current_workload | 0 |
| disk_available_least | 14759 |
| free_disk_gb | -4220 |
| free_ram_mb | 17628204 |
| local_gb | 16774 |
| local_gb_used | 20994 |
| memory_mb | 21228588 |
| memory_mb_used | 3600384 |
| running_vms | 212 |
| vcpus | 2600 |
| vcpus_used | 1430 |
+----------------------+----------+


Version-Release number of selected component (if applicable):


openstack-nova-api-14.1.0-22.el7ost.noarch                  Sat Jun 23 00:50:00 2018
openstack-nova-cert-14.1.0-22.el7ost.noarch                 Sat Jun 23 00:50:00 2018
openstack-nova-common-14.1.0-22.el7ost.noarch               Sat Jun 23 00:46:57 2018
openstack-nova-compute-14.1.0-22.el7ost.noarch              Sat Jun 23 00:49:10 2018
openstack-nova-conductor-14.1.0-22.el7ost.noarch            Sat Jun 23 00:50:00 2018
openstack-nova-console-14.1.0-22.el7ost.noarch              Sat Jun 23 00:50:00 2018
openstack-nova-migration-14.1.0-22.el7ost.noarch            Sat Jun 23 00:49:37 2018
openstack-nova-novncproxy-14.1.0-22.el7ost.noarch           Sat Jun 23 00:49:59 2018
openstack-nova-scheduler-14.1.0-22.el7ost.noarch            Sat Jun 23 00:50:00 2018
puppet-nova-9.6.0-3.el7ost.noarch                           Mon May  7 23:05:47 2018
python-nova-14.1.0-22.el7ost.noarch                         Sat Jun 23 00:46:55 2018
python-novaclient-6.0.2-2.el7ost.noarch                     Mon May  7 23:05:59 2018
openstack-cinder-9.1.4-33.el7ost.noarch                     Sat Jun 23 00:50:19 2018
puppet-cinder-9.5.0-6.el7ost.noarch                         Sat Jun 23 00:51:03 2018
python-cinder-9.1.4-33.el7ost.noarch                        Sat Jun 23 00:45:34 2018
python-cinderclient-1.9.0-6.el7ost.noarch                   Mon May  7 22:59:53 2018


How reproducible:

Every time

Steps to Reproduce:

Schedule instances with boot-from volumes on NFS storage. 

Actual results:

Instance gets filtered out from scheduling due to the diskfilter filter. 

Expected results:

Instances boots from volume and does not use ephemeral storage.

Additional info:

I think this is the same bug as mentioned here[1] which is marked closed wontfix. The customer is an EOSS customer and has asked for a fix for this issue. As a workaround we increased the disk_allocation_ratio on both the compute hosts and the controllers. This corrected the scheduling issue however now there is a concern that instances using local ephemeral storage will be scheduled on compute nodes with insufficient free space. 


[1] https://bugzilla.redhat.com/show_bug.cgi?id=1358912

Comment 5 Andreas Karis 2018-10-24 15:39:11 UTC
I'm adding a me too, for another customer.


Note You need to log in before you can comment on or make changes to this bug.