Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595705 - Upgrade to dnf-2.7.5-16.fc29.noarch breaks yum-utils
Summary: Upgrade to dnf-2.7.5-16.fc29.noarch breaks yum-utils
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-27 12:03 UTC by Jan Pazdziora
Modified: 2018-09-24 17:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-24 17:30:22 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2018-06-27 12:03:50 UTC
Description of problem:

With dnf-2.7.5-8.fc28.noarch found in today's docker.io/fedora:rawhide (5292e27c6dac) image, I'm able to install yum-utils.

When the dnf gets upgraded to dnf-2.7.5-16.fc29.noarch, it is no longer possible to install yum-utils due to dependencies.

Version-Release number of selected component (if applicable):

dnf-2.7.5-16.fc29.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. rpm -q dnf
2. dnf install yum-utils    # do not hit yes, cancel the operation
3. dnf upgrade -y dnf
4. rpm -q dnf
5. dnf install yum-utils

Actual results:

[root@c9666b98ff2e /]# rpm -q dnf
dnf-2.7.5-8.fc28.noarch
[root@c9666b98ff2e /]# dnf install yum-utils
Fedora - Rawhide - Developmental packages for t 4.5 MB/s |  61 MB     00:13    
Last metadata expiration check: 0:00:28 ago on Wed Jun 27 11:56:32 2018.
Dependencies resolved.
================================================================================
 Package                       Arch      Version               Repository  Size
================================================================================
Installing:
 yum-utils                     noarch    1.1.31-515.fc29       rawhide    117 k
Upgrading:
 gpgme                         x86_64    1.11.1-1.fc29         rawhide    273 k
 libcurl                       x86_64    7.60.0-1.fc29         rawhide    279 k
 openssl-libs                  x86_64    1:1.1.0h-5.fc29       rawhide    1.3 M
 python3-gpg                   x86_64    1.11.1-1.fc29         rawhide    231 k
 python3-rpm                   x86_64    4.14.1-10.fc29        rawhide    119 k
 rpm                           x86_64    4.14.1-10.fc29        rawhide    532 k
 rpm-build-libs                x86_64    4.14.1-10.fc29        rawhide    138 k
 rpm-libs                      x86_64    4.14.1-10.fc29        rawhide    329 k
 rpm-plugin-selinux            x86_64    4.14.1-10.fc29        rawhide     68 k
 rpm-plugin-systemd-inhibit    x86_64    4.14.1-10.fc29        rawhide     69 k
 rpm-sign-libs                 x86_64    4.14.1-10.fc29        rawhide     74 k
Installing dependencies:
 cpio                          x86_64    2.12-8.fc29           rawhide    264 k
 openssl                       x86_64    1:1.1.0h-5.fc29       rawhide    580 k
 pyliblzma                     x86_64    0.5.3-21.fc29         rawhide     55 k
 python2                       x86_64    2.7.15-2.fc29         rawhide    101 k
 python2-gpg                   x86_64    1.11.1-1.fc29         rawhide    225 k
 python2-iniparse              noarch    0.4-30.fc28           rawhide     47 k
 python2-kitchen               noarch    1.2.5-4.fc29          rawhide    122 k
 python2-libs                  x86_64    2.7.15-2.fc29         rawhide    6.2 M
 python2-pip                   noarch    9.0.3-2.fc29          rawhide    2.0 M
 python2-pycurl                x86_64    7.43.0.2-1.fc29       rawhide    226 k
 python2-pyxattr               x86_64    0.5.3-16.fc28         rawhide     35 k
 python2-rpm                   x86_64    4.14.1-10.fc29        rawhide    120 k
 python2-setuptools            noarch    39.2.0-1.fc29         rawhide    643 k
 python2-six                   noarch    1.11.0-3.fc28         rawhide     37 k
 python2-urlgrabber            noarch    3.10.1-15.fc29        rawhide    112 k
 yum                           noarch    3.4.3-518.fc29        rawhide    1.2 M
 yum-metadata-parser           x86_64    1.1.4-22.fc29         rawhide     41 k
Installing weak dependencies:
 openssl-pkcs11                x86_64    0.4.7-7.fc29          rawhide     58 k

Transaction Summary
================================================================================
Install  19 Packages
Upgrade  11 Packages

Total download size: 16 M
Is this ok [y/N]: n
Operation aborted.
[root@c9666b98ff2e /]# dnf upgrade -y dnf
Last metadata expiration check: 0:00:51 ago on Wed Jun 27 11:56:32 2018.
Dependencies resolved.
================================================================================
 Package                    Arch        Version              Repository    Size
================================================================================
Upgrading:
 dnf                        noarch      2.7.5-16.fc29        rawhide      406 k
 dnf-yum                    noarch      2.7.5-16.fc29        rawhide      126 k
 glib2                      x86_64      2.56.1-4.fc29        rawhide      2.5 M
 python3-dnf                noarch      2.7.5-16.fc29        rawhide      543 k
Installing dependencies:
 dnf-data                   noarch      2.7.5-16.fc29        rawhide      124 k
     replacing  dnf-conf.noarch 2.7.5-8.fc28
 gobject-introspection      x86_64      1.56.1-1.fc29        rawhide      254 k
 libmodulemd                x86_64      1.5.2-1.fc29         rawhide      120 k
 python3-gobject-base       x86_64      3.28.3-1.fc29        rawhide      311 k
Installing weak dependencies:
 shared-mime-info           x86_64      1.9-4.fc29           rawhide      327 k

Transaction Summary
================================================================================
Install  5 Packages
Upgrade  4 Packages

Total download size: 4.6 M
Downloading Packages:
(1/9): dnf-data-2.7.5-16.fc29.noarch.rpm        269 kB/s | 124 kB     00:00    
(2/9): libmodulemd-1.5.2-1.fc29.x86_64.rpm      257 kB/s | 120 kB     00:00    
(3/9): python3-gobject-base-3.28.3-1.fc29.x86_6 539 kB/s | 311 kB     00:00    
(4/9): gobject-introspection-1.56.1-1.fc29.x86_ 1.3 MB/s | 254 kB     00:00    
(5/9): shared-mime-info-1.9-4.fc29.x86_64.rpm   1.2 MB/s | 327 kB     00:00    
(6/9): dnf-2.7.5-16.fc29.noarch.rpm             1.8 MB/s | 406 kB     00:00    
(7/9): dnf-yum-2.7.5-16.fc29.noarch.rpm         1.1 MB/s | 126 kB     00:00    
(8/9): python3-dnf-2.7.5-16.fc29.noarch.rpm     2.0 MB/s | 543 kB     00:00    
(9/9): glib2-2.56.1-4.fc29.x86_64.rpm           3.6 MB/s | 2.5 MB     00:00    
--------------------------------------------------------------------------------
Total                                           1.5 MB/s | 4.6 MB     00:03     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Running scriptlet: glib2-2.56.1-4.fc29.x86_64                             1/1 
  Upgrading        : glib2-2.56.1-4.fc29.x86_64                            1/14 
  Installing       : libmodulemd-1.5.2-1.fc29.x86_64                       2/14 
  Installing       : gobject-introspection-1.56.1-1.fc29.x86_64            3/14 
  Installing       : python3-gobject-base-3.28.3-1.fc29.x86_64             4/14 
  Installing       : dnf-data-2.7.5-16.fc29.noarch                         5/14 
  Upgrading        : python3-dnf-2.7.5-16.fc29.noarch                      6/14 
  Upgrading        : dnf-2.7.5-16.fc29.noarch                              7/14 
  Running scriptlet: dnf-2.7.5-16.fc29.noarch                              7/14 
  Upgrading        : dnf-yum-2.7.5-16.fc29.noarch                          8/14 
  Installing       : shared-mime-info-1.9-4.fc29.x86_64                    9/14 
  Running scriptlet: shared-mime-info-1.9-4.fc29.x86_64                    9/14 
  Cleanup          : dnf-yum-2.7.5-8.fc28.noarch                          10/14 
  Running scriptlet: dnf-2.7.5-8.fc28.noarch                              11/14 
  Cleanup          : dnf-2.7.5-8.fc28.noarch                              11/14 
  Running scriptlet: dnf-2.7.5-8.fc28.noarch                              11/14 
  Cleanup          : python3-dnf-2.7.5-8.fc28.noarch                      12/14 
  Obsoleting       : dnf-conf-2.7.5-8.fc28.noarch                         13/14 
  Cleanup          : glib2-2.55.2-3.fc28.x86_64                           14/14 
  Running scriptlet: glib2-2.55.2-3.fc28.x86_64                           14/14 
System has not been booted with systemd as init system (PID 1). Can't operate.
  Running scriptlet: glib2-2.56.1-4.fc29.x86_64                           14/14 
  Running scriptlet: shared-mime-info-1.9-4.fc29.x86_64                   14/14 
  Verifying        : dnf-data-2.7.5-16.fc29.noarch                         1/14 
  Verifying        : python3-gobject-base-3.28.3-1.fc29.x86_64             2/14 
  Verifying        : libmodulemd-1.5.2-1.fc29.x86_64                       3/14 
  Verifying        : gobject-introspection-1.56.1-1.fc29.x86_64            4/14 
  Verifying        : shared-mime-info-1.9-4.fc29.x86_64                    5/14 
  Verifying        : dnf-2.7.5-16.fc29.noarch                              6/14 
  Verifying        : python3-dnf-2.7.5-16.fc29.noarch                      7/14 
  Verifying        : dnf-yum-2.7.5-16.fc29.noarch                          8/14 
  Verifying        : glib2-2.56.1-4.fc29.x86_64                            9/14 
  Verifying        : glib2-2.55.2-3.fc28.x86_64                           10/14 
  Verifying        : dnf-2.7.5-8.fc28.noarch                              11/14 
  Verifying        : dnf-conf-2.7.5-8.fc28.noarch                         12/14 
  Verifying        : dnf-yum-2.7.5-8.fc28.noarch                          13/14 
  Verifying        : python3-dnf-2.7.5-8.fc28.noarch                      14/14 

Installed:
  shared-mime-info.x86_64 1.9-4.fc29           dnf-data.noarch 2.7.5-16.fc29    
  gobject-introspection.x86_64 1.56.1-1.fc29   libmodulemd.x86_64 1.5.2-1.fc29  
  python3-gobject-base.x86_64 3.28.3-1.fc29   

Upgraded:
  dnf.noarch 2.7.5-16.fc29            dnf-yum.noarch 2.7.5-16.fc29             
  glib2.x86_64 2.56.1-4.fc29          python3-dnf.noarch 2.7.5-16.fc29         

Complete!
[root@c9666b98ff2e /]# rpm -q dnf
dnf-2.7.5-16.fc29.noarch
[root@c9666b98ff2e /]# dnf install yum-utils
Last metadata expiration check: 0:01:06 ago on Wed Jun 27 11:56:32 2018.
Error: 
 Problem: problem with installed package dnf-yum-2.7.5-16.fc29.noarch
  - package dnf-yum-2.7.5-16.fc29.noarch conflicts with yum provided by yum-3.4.3-518.fc29.noarch
  - package yum-utils-1.1.31-515.fc29.noarch requires yum >= 3.4.3-148, but none of the providers can be installed
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Expected results:

Even with latest dnf, yum-utils can be installed.

Additional info:

Comment 1 Jan Pazdziora 2018-06-27 12:05:42 UTC
I've also found bug 1467060 and bug 1538815 that might be partially relevant.

Maybe this bugzilla should be filed against yum-utils ... but it's dnf that has changed and left rawhide in inconsistent state, so the fix likely needs to be driven from the dnf side.

Comment 2 Marek Blaha 2018-06-27 13:28:38 UTC
yum-utils can be installed with latest dnf. It's dnf-yum package which conflicts with yum (required by yum-utils):

# dnf install yum-utils --allowerasing
Last metadata expiration check: 0:16:48 ago on Wed Jun 27 13:10:14 2018.
Dependencies resolved.
==========================================================================================
 Package                          Arch         Version               Repository      Size
==========================================================================================
Installing:
 yum-utils                        noarch       1.1.31-515.fc29       rawhide        117 k
Upgrading:
 gpgme                            x86_64       1.11.1-1.fc29         rawhide        273 k
 libcurl                          x86_64       7.60.0-1.fc29         rawhide        279 k
 openssl-libs                     x86_64       1:1.1.0h-5.fc29       rawhide        1.3 M
 python3-gpg                      x86_64       1.11.1-1.fc29         rawhide        231 k
 python3-rpm                      x86_64       4.14.1-10.fc29        rawhide        119 k
 rpm                              x86_64       4.14.1-10.fc29        rawhide        532 k
 rpm-build-libs                   x86_64       4.14.1-10.fc29        rawhide        138 k
 rpm-libs                         x86_64       4.14.1-10.fc29        rawhide        329 k
 rpm-plugin-selinux               x86_64       4.14.1-10.fc29        rawhide         68 k
 rpm-plugin-systemd-inhibit       x86_64       4.14.1-10.fc29        rawhide         69 k
 rpm-sign-libs                    x86_64       4.14.1-10.fc29        rawhide         74 k
Installing dependencies:
 cpio                             x86_64       2.12-8.fc29           rawhide        264 k
 openssl                          x86_64       1:1.1.0h-5.fc29       rawhide        580 k
 pyliblzma                        x86_64       0.5.3-21.fc29         rawhide         55 k
 python2                          x86_64       2.7.15-2.fc29         rawhide        101 k
 python2-gpg                      x86_64       1.11.1-1.fc29         rawhide        225 k
 python2-iniparse                 noarch       0.4-30.fc28           rawhide         47 k
 python2-kitchen                  noarch       1.2.5-4.fc29          rawhide        122 k
 python2-libs                     x86_64       2.7.15-2.fc29         rawhide        6.2 M
 python2-pip                      noarch       9.0.3-2.fc29          rawhide        2.0 M
 python2-pycurl                   x86_64       7.43.0.2-1.fc29       rawhide        226 k
 python2-pyxattr                  x86_64       0.5.3-16.fc28         rawhide         35 k
 python2-rpm                      x86_64       4.14.1-10.fc29        rawhide        120 k
 python2-setuptools               noarch       39.2.0-1.fc29         rawhide        643 k
 python2-six                      noarch       1.11.0-3.fc28         rawhide         37 k
 python2-urlgrabber               noarch       3.10.1-15.fc29        rawhide        112 k
 yum                              noarch       3.4.3-518.fc29        rawhide        1.2 M
 yum-metadata-parser              x86_64       1.1.4-22.fc29         rawhide         41 k
Installing weak dependencies:
 openssl-pkcs11                   x86_64       0.4.7-7.fc29          rawhide         58 k
Removing dependent packages:
 dnf-yum                          noarch       2.7.5-16.fc29         @rawhide        22 k

Transaction Summary
==========================================================================================
Install  19 Packages
Upgrade  11 Packages
Remove    1 Package

Total download size: 16 M
Is this ok [y/N]:

Comment 3 Jan Pazdziora 2018-07-02 14:32:10 UTC
Well, dnf-yum is built from dnf source, there is no dnf-yum component.

And it's not a NOTABUG because I've hit it again today, with

[root@e1cc7190897a /]# rpm -q dnf
dnf-3.0.1-1.fc29.noarch
[root@e1cc7190897a /]# dnf install yum-utils
Last metadata expiration check: 0:00:56 ago on Mon Jul  2 14:28:42 2018.
Error: 
 Problem: problem with installed package dnf-yum-3.0.1-1.fc29.noarch
  - package dnf-yum-3.0.1-1.fc29.noarch conflicts with yum provided by yum-3.4.3-518.fc29.noarch
  - package yum-utils-1.1.31-515.fc29.noarch requires yum >= 3.4.3-148, but none of the providers can be installed
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Comment 4 Jan Kurik 2018-08-14 11:05:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Jaroslav Mracek 2018-09-24 17:30:22 UTC
The problem will be fixed in dnf-3.6.0


Note You need to log in before you can comment on or make changes to this bug.