Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159570 - Anaconda fails to install on a disk with FreeBSD partition
Summary: Anaconda fails to install on a disk with FreeBSD partition
Keywords:
Status: CLOSED DUPLICATE of bug 124843
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-04 18:16 UTC by Uri Sharf
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-07 16:02:52 UTC


Attachments (Terms of Use)

Description Uri Sharf 2005-06-04 18:16:56 UTC
Description of problem:   
   
Can not start install ofr Test3 on a 40GB which has a FreeBSD installed. 
   
Version-Release number of selected component (if applicable):   
   
   
How reproducible:   
   
  Install FC4-Test3 on a disk with FreeBSD installed on a primary partition. 
   
Steps to Reproduce:   
1.  Install FreeBSD on to primary partition 
2.  Run fedora core install (in my case network install over ftp) 
3.   
     
Actual results:   
   
  Anaconda aborts when after it suggests to test the Media. When trying to 
install from the hard disk (dvd iso), I've noticed a strange list of suggested 
partitions to select from (when pointing anaconda to the ISO on the hard 
disk). 
 
Expected results:   
   
   
Additional info:   
 
I've seen something similair with Mandriva, when it tries to mount /dev/hda2 
as VFAT/NTFS, while this is actually the FreeBSD one. SUSE 9.2 Managed to 
install w/o any problems on the same setup. 
 
inspiron:~ # fdisk -l /dev/hda 
 
Disk /dev/hda: 40.0 GB, 40007761920 bytes 
16 heads, 63 sectors/track, 77520 cylinders 
Units = cylinders of 1008 * 512 = 516096 bytes 
 
   Device Boot      Start         End      Blocks   Id  System 
/dev/hda1               1          64       32098+   6  FAT16 
Partition 1 does not end on cylinder boundary. 
/dev/hda2              64       16925     8498070   a5  FreeBSD 
/dev/hda3           16926       77520    30539565    f  W95 Ext'd (LBA) 
Partition 3 does not end on cylinder boundary. 
/dev/hda5           16926       17978      530113+  82  Linux swap / Solaris 
/dev/hda6           17978       18297      160618+  83  Linux 
/dev/hda7           18297       28465     5124703+  83  Linux 
/dev/hda8           28465       38633     5124703+  83  Linux 
/dev/hda9           38633       77520    19599268+  83  Linux

Comment 1 Chris Lumens 2005-06-07 16:02:52 UTC

*** This bug has been marked as a duplicate of 124843 ***


Note You need to log in before you can comment on or make changes to this bug.