Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159553 - Drawer opens on wrong display
Summary: Drawer opens on wrong display
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-04 00:22 UTC by Norm Brake
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-22 15:38:53 UTC


Attachments (Terms of Use)

Description Norm Brake 2005-06-04 00:22:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
With two gnome managed displays, a drawer on a panel of display :0.1 opens on :0.0.  Applications invoked by launchers on that drawer also start on :0.0.  this is somewhat counter intuitive sine other launchers on the parent panel launch applications to :0.1.


Version-Release number of selected component (if applicable):
gnome-panel-2.8.1-3

How reproducible:
Always

Steps to Reproduce:
1.On system with two gnome managed displays, create a drawer on a panel at top of :0.1
2. click on the drawer.
3. observe the open drawer on :0.0
  

Actual Results:  Observed drawer slide appear on the :0.0 display.

Expected Results:  Drawer slide should have appeared on :0.1 where the drawer icon was.

Additional info:

IBM T30 notebook computer with two monitors on same controler.  One is the notebook screen which is smaller than the CRT so when the drawer is on a bottom panel, it looks like the drawer doesn't open at all since the image is below the visable area on the notebook screen (:0.0).  With the drawer on a top panel of the CRT (:0.1), the open drawer can be seen at the top of the notebook screen (:0.0).

Comment 1 Norm Brake 2005-06-18 01:46:43 UTC
This appears to be fixed in Fedora Core 4 so, as far as I'm concerned, this bug
report can be closed.


Comment 2 Mark McLoughlin 2005-06-22 15:38:53 UTC
Thanks for the update


Note You need to log in before you can comment on or make changes to this bug.