Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595279 - avc: denied { sys_nice } for comm="numad"
Summary: avc: denied { sys_nice } for comm="numad"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-26 13:22 UTC by Pat Riehecky
Modified: 2019-02-27 15:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-27 15:11:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pat Riehecky 2018-06-26 13:22:17 UTC
Description of problem:
numad appears to be trying to alter its own nice value on my system.  Selinux is blocking this behavior.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-192.el7_5.3.noarch

How reproducible:
100%

Steps to Reproduce:
1.start numad
2.
3.

Actual results:
type=AVC msg=audit(1530003672.185:23676): avc:  denied  { sys_nice } for  pid=1094 comm="numad" capability=23  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:numad_t:s0 tclass=capability
type=AVC msg=audit(1530003672.186:23677): avc:  denied  { sys_nice } for  pid=1094 comm="numad" capability=23  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:numad_t:s0 tclass=capability
type=AVC msg=audit(1530003672.186:23678): avc:  denied  { sys_nice } for  pid=1094 comm="numad" capability=23  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:numad_t:s0 tclass=capability
type=AVC msg=audit(1530003672.186:23679): avc:  denied  { sys_nice } for  pid=1094 comm="numad" capability=23  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:numad_t:s0 tclass=capability
type=AVC msg=audit(1530003672.186:23680): avc:  denied  { sys_nice } for  pid=1094 comm="numad" capability=23  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:numad_t:s0 tclass=capability


Expected results:
no selinux errors

Additional info:
I believe this should resolve.

allow numad_t self:capability sys_nice;

Comment 2 Zdenek Pytela 2019-02-27 15:11:11 UTC
This issue was not selected to be included in Red Hat Enterprise Linux 7.7 because it is seen either as low or moderate impact to a small number of use-cases. The next release will be in Maintenance Support 1 Phase, which means that qualified Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released as they become available.

We will now close this issue, but if you believe that it qualifies for the Maintenance Support 1 Phase, please re-open; otherwise, we recommend moving the request to Red Hat Enterprise Linux 8 if applicable.


Note You need to log in before you can comment on or make changes to this bug.