Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595165 - Babel warning: No hyphenation patterns were preloaded for the language `French'/`German'/?
Summary: Babel warning: No hyphenation patterns were preloaded for the language `Frenc...
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-26 09:33 UTC by Skippy
Modified: 2019-01-07 11:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-26 20:31:37 UTC


Attachments (Terms of Use)

Description Skippy 2018-06-26 09:33:14 UTC
As the title says, babel can't find French hyphenation patterns.  There is no such warning for English, but I tested with German and it has the same issue.

Both texlive-babel-french and texlive-hyphen-french are installed.  I tried running `fmtutil -sys -all` as suggested on the web, and also `texhash`, but it didn't help.

Below is the end of /usr/share/texlive/texmf-dist/tex/generic/config/language.dat after installation of texlive-hyphen-french and texlive-hyphen-german :
--------------------------------------------------------------------
dumylang        dumyhyph.tex    %for testing a new language.
nohyphenation   zerohyph.tex    %a language with no patterns at all.
french loadhyph-fr.tex
=patois
=francais
german loadhyph-de-1901.tex
ngerman loadhyph-de-1996.tex
swissgerman loadhyph-de-ch-1901.tex
--------------------------------------------------------------------

I thought it might have been a path issue, so I linked loadhyph-*.tex files from /usr/share/texlive/texmf-dist/tex/generic/hyph-utf8/loadhyph/ into /usr/share/texlive/texmf-dist/tex/generic/hyphen/ (then ran again fmtutil and texhash) but it didn't change anything.

Not sure the packages list would be relevant, let me know if you think it is.

Comment 1 Guilherme D. da Fonseca 2018-11-10 11:57:05 UTC
The bug persists on Fedora 29 and I have not found any workaround yet.

I installed all texlive packages including:

texlive-collection-langfrench-svn40375-21.fc29.noarch
texlive-lshort-french-doc-svn23332.5.01fr_0-21.fc29.noarch
texlive-hyphen-french-svn41113-21.fc29.noarch
texlive-bibleref-french-svn35497.2.3.1-21.fc29.noarch
texlive-e-french-svn45091-21.fc29.noarch
texlive-babel-french-svn48222-21.fc29.noarch
texlive-l2tabu-french-doc-svn31315.2.3-21.fc29.noarch

I tried running fmtutil-sys -all, fmtutil-sys --refresh, and texhash as root and the problem persists. Anyway, I believe that if anything had to be run to inform latex of the new installed package, the execution should be automated inside the rpm, right?

I will keep trying to find a workaround.

Comment 2 Guilherme D. da Fonseca 2018-11-10 13:19:10 UTC
The problem is only with pdflatex. When I use the latex command to compile to dvi, everything works fine. Therefore, a workaround is to use latex to compile to dvi, followed by dvips and ps2pdf.

Comment 3 Guilherme D. da Fonseca 2018-11-25 16:04:48 UTC
Removing the directory ~/.texlive2018 and using the latest version of texlive solved the problem. This directory has been created by some previous execution of pdflatex (already on Fedora 29, because I installed from scratch), but maybe before the hyphenation packages had been installed. Further tests are needed to determine if the bug persists in the latest version when a user installs the hyphenation packages after ~/.texlive2018 has been created.

Comment 4 Tom "spot" Callaway 2018-11-26 20:31:37 UTC
Closing as NOTABUG, feel free to reopen if you (or anyone) can reproduce on a fresh install.

Comment 5 Víctor R. Ruiz 2019-01-02 00:06:33 UTC
I also have a similar issue with pdflatex, Spanish babel and Fedora 29. These are the packages that I have installed:

texlive-l2tabu-spanish-doc-svn15878.1.1-23.fc29.noarch
texlive-hyphen-spanish-svn40340-23.fc29.noarch
texlive-latex2e-help-texinfo-spanish-svn48139-23.fc29.noarch
texlive-collection-langspanish-svn40587-23.fc29.noarch
texlive-babel-spanish-svn39920-23.fc29.noarch
texlive-lshort-spanish-doc-svn35050.0.5-23.fc29.noarch
texlive-spanish-mx-svn15878.1.1a-23.fc29.noarch

I deleted the ~/.texlive2018 directory on my system and run fmtutil-sys -all and fmutil-sys --refresh, but that didn't work.

$ tail -n 6 /usr/share/texlive/texmf-dist/tex/generic/config/language.dat 
% 
dumylang	dumyhyph.tex    %for testing a new language.
nohyphenation	zerohyph.tex    %a language with no patterns at all.
galician loadhyph-gl.tex
catalan loadhyph-ca.tex

After manually adding "spanish loadhyph-es.tex" line to language.dat, the babel warning is gone and hyphenation in Spanish works fine.

Comment 6 Tom "spot" Callaway 2019-01-02 17:18:57 UTC
This is weird. The texlive-hyphen-spanish package has this %post scriptlet:

%post hyphen-spanish
if [ $1 -gt 0 ] ; then
sed -i '/spanish.*/d' %{_texdir}/texmf-dist/tex/generic/config/language.dat
echo "spanish loadhyph-es.tex" >> %{_texdir}/texmf-dist/tex/generic/config/language.dat
sed -i '/=espanol/d' %{_texdir}/texmf-dist/tex/generic/config/language.dat
echo "=espanol" >> %{_texdir}/texmf-dist/tex/generic/config/language.dat
sed -i '/\\addlanguage{spanish}.*/d' %{_texdir}/texmf-dist/tex/generic/config/language.def
echo "\addlanguage{spanish}{loadhyph-es.tex}{}{2}{2}" >> %{_texdir}/texmf-dist/tex/generic/config/language.def
sed -i '/\\addlanguage{espanol}.*/d' %{_texdir}/texmf-dist/tex/generic/config/language.def
echo "\addlanguage{espanol}{loadhyph-es.tex}{}{2}{2}" >> %{_texdir}/texmf-dist/tex/generic/config/language.def
fi
:

In plain language, this means that if texlive-hyphen-spanish is installed or upgraded, it should be putting "spanish loadhyph-es.tex" into /usr/share/texlive/texmf-dist/tex/generic/config/language.dat.

I tested this on my local Fedora 29 system, which did not have texlive-hyphen-spanish installed (and had no entry for spanish in language.dat). After installing texlive-hyphen-spanish via dnf, I saw two new lines in language.dat (at the bottom):

spanish loadhyph-es.tex
=espanol

*****

So basically, I'm not sure how the scriptlet did not get run for you, unless you installed that package in an odd way (or did something like --noscripts when installing it).

Comment 7 raquin 2019-01-07 11:09:26 UTC
Hello,

I use Fedora 29. I do have the following lines in my language.dat file:

french loadhyph-fr.tex
=patois
=francais

but giving the "french" argument to polyglossia reproduces the bug. However, when I use "francais", the hyphenation patterns are correctly loaded (but polyglossia doesn't load `gloss-french.ldf`, and tries to load `gloss-francais.ldf` instead).

It's also a bug for babel, but giving "francais" as an argument doesn't fix it.


Note You need to log in before you can comment on or make changes to this bug.