Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595119 - can't create more than one CDROMs
Summary: can't create more than one CDROMs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: UI
Version: 0.11.26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Greg Sheremeta
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-26 07:55 UTC by Xu Tian
Modified: 2018-08-15 17:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-15 16:59:23 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description Xu Tian 2018-06-26 07:55:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Xu Tian 2018-06-26 08:11:53 UTC
If I create a windows guest with virtio disk, I need to attached extra virtio-win.iso as cdrom to make windows installer load virtio disk driver from the cdrom. but in "Create VM" -> "Boot Option" table only one cdrom can be attached to VM.

Version-Release number of selected component (if applicable):

cockpit-ws-160-1.el7.centos.x86_64

Steps to Reproduce:
1. install ovirt-engine
2. login in ovirt-engine from web UI
3. create virtual machine "计算"->"虚拟机"

Actual results:

one only cdrom can be attached to VM

Expected results:

Allow user to attach more than one cdrom

Comment 2 Michal Skrivanek 2018-06-27 04:43:52 UTC
ovirt supports only one cdrom except for special cases of cloud-init or payload iso

Comment 3 Michal Skrivanek 2018-08-15 16:59:50 UTC
note you could use floppy for drivers

Comment 4 Ryan Barry 2018-08-15 17:04:12 UTC
Windows pre-caches all the files, and the recommended way to do this (in oVirt and other hypervisors) is to eject the cdrom, insert the driver disk, load the drivers, then swap back to the Windows ISO.

Closing, since we don't support multiple CDROMs. Please re-open if the workaround doesn't work, or there's another use case for this.


Note You need to log in before you can comment on or make changes to this bug.