Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1595014 - BackupPC needs configuration changes to account for changes in httpd
Summary: BackupPC needs configuration changes to account for changes in httpd
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: BackupPC
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-26 01:05 UTC by Richard Schaal
Modified: 2018-07-11 12:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-11 12:29:25 UTC


Attachments (Terms of Use)

Description Richard Schaal 2018-06-26 01:05:03 UTC
Description of problem: Fedora 28 versions of BackupPC and httpd are not compatible in that BackupPC needs mod_scgi.so, and httpd discontinued the code distribution.  I am not sure when the module distribution was stopped,- it could have been several years ago.  

The problem is that setting up BackupPC in the most efficient and secure manner which is recommended by the documentation does not result in any files being backed up because a key component is missing.  It is possible that the httpd modules mod_proxy.so and mod_proxy_scgi.so are intended to replace mod_scgi.so.  There are hints to that in some of my reading, but I am too feebleminded to understand exactly how.


Version-Release number of selected component (if applicable):


How reproducible: Code inspection shows the dependency on mod_scgi.so in the file /etc/httpd/conf.d/BackupPC.conf


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info: I would be happy to help you test any patch on my home network.

Comment 1 Richard Shaw 2018-07-01 14:48:06 UTC
First I need to understand what you're asking me to do. There is a lot of manual setup for scgi (which is why I don't use it personally) that either can not, or is impractical to implement/automate in the package.

Comment 2 Richard Schaal 2018-07-01 21:12:02 UTC
Can this distributed file:

/etc/httpd/conf.d/BackupPC.conf

be changed to use mod_proxy.so and mod_proxy_scgi.so or do the two modules not make a functional replacement for mod_scgi.so ?

The description of the methods of configuration for BackupPC make the SCGI approach sound like the best method to run with.  The documentation describes how to do the configuration, but the package has a broken dependency.

I don't know what the best resolution would be.  If the Apache folks could be persuaded to add mod_scgi.so to their distribution, that would do the trick.  Lacking that, MAYBE a configuration change for BackupPC could accommodate the use of mod_proxy.so and mod_proxy_scgi.so ?

I am reluctant to use one of the alternate configuration methods as the BackupPC documentation made such a good case for using SCGI. And pointed out security and performance shortcomings with the other methods.

Comment 3 Richard Shaw 2018-07-02 01:11:13 UTC
You can experiment and see if you can get it to work with mod_proxy_scgi but it's actually less secure unless you control who can access the port. The current configuration using basic authentication has worked well and is easier to setup.

Comment 4 Richard Shaw 2018-07-11 12:29:25 UTC
If you can get it working and help me figure out how to make it work and can help figure out how to manage it withing a packaging framework I'll consider it, but BackupPC has been setup the current way for many years and is used by a lot of people so I am hesitant to make the change.


Note You need to log in before you can comment on or make changes to this bug.