Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1594952 - [3.10] Add Ability to suppress event log messages
Summary: [3.10] Add Ability to suppress event log messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.10.z
Assignee: ravig
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On: 1569137
Blocks: 1594888 1594944 1594950
TreeView+ depends on / blocked
 
Reported: 2018-06-25 19:56 UTC by ravig
Modified: 2018-08-31 06:18 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1569137
Environment:
Last Closed: 2018-08-31 06:18:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3455951 None None None 2018-06-25 19:56:56 UTC
Red Hat Product Errata RHBA-2018:2376 None None None 2018-08-31 06:18:58 UTC

Comment 3 Seth Jennings 2018-07-31 15:46:20 UTC
Origin 3.10 PR:
https://github.com/openshift/origin/pull/20441

Comment 4 Weinan Liu 2018-08-02 07:39:29 UTC
Steps to reproduce:
1. Reboot (master or node) then update /etc/resolv.conf to include more than 3 doamins. (e.g. search cluster.local ec2.internal kube-system.svc.cluster.local svc.cluster.local cluster.local kubelet.kubernetes.rancher.internal kubernetes.rancher.internal rancher.internal c.rancher-qa.internal google.internal
)

2. Check if overmuch lines of CheckLimitsForResolvConf error generated
# journalctl --since="1 hour ago"| grep -i CheckLimitsForResolvConf

Issue still not fixed on 3.10.27
[root@ip-172-18-2-209 ~]# oc version
oc v3.10.27
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-18-2-209.ec2.internal:8443
openshift v3.10.27
kubernetes v1.10.0+b81c8f8

Comment 6 Weinan Liu 2018-08-21 05:25:56 UTC
[root@ip-172-18-0-23 ~]# journalctl --since="1 hour ago"| grep -i CheckLimitsForResolvConf

[root@ip-172-18-0-23 ~]# 

Verified to be fixed on openshift v3.10.28

Comment 8 errata-xmlrpc 2018-08-31 06:18:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2376


Note You need to log in before you can comment on or make changes to this bug.