Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159491 - Several bugs with the installer's text-mode package selection
Summary: Several bugs with the installer's text-mode package selection
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-06-02 22:09 UTC by John Caruso
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-31 21:07:51 UTC


Attachments (Terms of Use)

Description John Caruso 2005-06-02 22:09:54 UTC
Description of problem:

When doing a text-mode install of RHEL4, there are several bugs (or questionable
behaviors) in the package selection portion of the process:

1) Including a package group (e.g. "Server Configuration Tools") will often not
cause the "Total install size" to be updated.  To get it to update, it's often
necessary to select and then unselect some other package group several times.

2) If you use F2 ("Group Details") to customize a package group, make some
changes, and then use F2 again on the same package group, the changes you've
made will be forgotten and the group will have been reset to its default
settings.  This makes it impossible to verify that you've customized the group
correctly.  And...

3) ...the "Total install size" also isn't updated correctly all the time when
you use F2 to customize a package group.


Version-Release number of selected component (if applicable):

This has been happening since RHEL3, and apparently hasn't been fixed under RHEL4.

How reproducible:

Perform a text-mode install ("linux text").

Comment 2 Jeremy Katz 2006-01-31 21:07:51 UTC
This should be fxied in the rework of this screen in FC5

Comment 3 John Caruso 2006-01-31 21:10:43 UTC
FC5/Rawhide is Fedora, right?  I've reported this bug for RHEL, not Fedora.  Are
you saying this fix will find its way into RHEL4 as well?


Note You need to log in before you can comment on or make changes to this bug.