Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1594873 - Provisioning embedded ansible service dialog fails
Summary: Provisioning embedded ansible service dialog fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Bill Wei
QA Contact: Kedar Kulkarni
URL:
Whiteboard:
: 1596111 (view as bug list)
Depends On:
Blocks: 1595418
TreeView+ depends on / blocked
 
Reported: 2018-06-25 15:14 UTC by Adam Grare
Modified: 2019-02-11 14:09 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1595418 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:09:04 UTC
Category: Bug
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Adam Grare 2018-06-25 15:14:16 UTC
Upstream issue: https://github.com/ManageIQ/manageiq/issues/17535


If I create a new Catalog Item in Services -> Catalogs -> Catalog Items of type "Ansible Playbook" (following this guide and order it from within Services -> Service Catalogs, then I get following error in evm.log:

[----] E, [2018-06-06T13:34:42.476477 #44488:89ef18] ERROR -- : Q-task_id([r5_service_template_provision_request_5]) [NameError]: undefined local variable or method `ext_management_system' for #<ServiceTemplateAnsiblePlaybook:0x0000000014e517f8>
Did you mean?  old_ext_management_system  Method:[block in method_missing]
[----] E, [2018-06-06T13:34:42.476758 #44488:89ef18] ERROR -- : Q-task_id([r5_service_template_provision_request_5]) /home/miha/.rbenv/versions/2.4.3/gemsets/miq/gems/activemodel-5.0.7/lib/active_model/attribute_methods.rb:433:in `method_missing'
/home/miha/git-repos/manageiq/app/models/mixins/archived_mixin.rb:29:in `my_zone'
/home/miha/git-repos/manageiq/app/models/service_template_provision_task.rb:146:in `deliver_to_automate'
/home/miha/git-repos/manageiq/app/models/miq_request.rb:456:in `block in create_request_tasks'
/home/miha/git-repos/manageiq/app/models/miq_request.rb:453:in `each'

Comment 2 Adam Grare 2018-06-25 15:15:01 UTC
https://github.com/ManageIQ/manageiq/pull/17539

Comment 4 Chris Pelland 2018-06-28 18:59:51 UTC
*** Bug 1596111 has been marked as a duplicate of this bug. ***

Comment 5 Kedar Kulkarni 2018-07-02 18:17:07 UTC
ON 5.10.0.2 I was able to order ansible services catalog items and it executed successfully.


Note You need to log in before you can comment on or make changes to this bug.