Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159451 - Bind Seems to hang for a few seconds...randomly
Summary: Bind Seems to hang for a few seconds...randomly
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 19:17 UTC by CDapplications
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-03 16:34:56 UTC


Attachments (Terms of Use)

Description CDapplications 2005-06-02 19:17:38 UTC
Description of problem:
Port 53 open/no firewall - available at 100% confirmed
UDP queries to bindDNS timeout randomly (sometimes ok, sometimes timeout at no
regular intervals)

Version-Release number of selected component (if applicable):
bind 9.2.5

How reproducible:
Well, I have tried everything on the server...
I does it continuously and randomly

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jason Vas Dias 2005-06-02 19:38:09 UTC
You may not have port 53 blocked on your machine, but are you positive nothing
in the path between your machine and some root nameservers has port 53 
blocked ? (NOTE: it is typical ISP behaviour to block this port to all but
their own nameservers). 
Are you using NetworkManager ?
Do you have SELinux enabled ?
Can you reproduce the timeout with 
  options { ...
            query-source port 53;
            ...
          }; 
in /etc/named.conf ?
If so, please try to reproduce the problem with debugging / tracing enabled -
please run these commands:
  tcpdump -vvv -nl -i any -s 2048 port domain 2>&1 | tee /tmp/tcpdump.log &
  . /etc/sysconfig/named; touch ${ROOTDIR}/var/named/named.run; 
  chown named:named ${ROOTDIR}/var/named/named.run;
  rndc trace 99;
and then reproduce the problem.
When you have reproduced it:
  pkill tcpdump
  rndc trace 0
and append the /tmp/tcpdump.log and $ROOTDIR/var/named/named.run files 
to this bug report. Your named.conf and zone files if any would also be
most useful in tracking down the problem.
I've not been able to reproduce this problem with bind-9.2.5 on FC-3, both 
behind a firewall and on external internet, in forward or authoritative
modes, with SELinux disabled or enabled, so further information is required
to diagnose this problem.


   

 

Comment 2 CDapplications 2005-06-03 16:12:53 UTC
Hello Jason.

What a shame on me... In fact, after many questions asked, since monday, to 
the datacenter hosting the servers and many answers given : 'it is not our 
network, it your server...', I looked at all the solutions possible on the 
software side.
But the solution came last night...a switch failed putting all their network 
down for more than 3 hours. The cause of the timeout is (i presume) this 
switch that was already showing signs of fatigue.
Now, I don't have any time out anymore.
Sorry for the time you spent answering my bug. Anyway I would like to thank 
you a lot.

Regards,

Christophe

Comment 3 Jason Vas Dias 2005-06-03 16:34:56 UTC
No problem - closing out .


Note You need to log in before you can comment on or make changes to this bug.