Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159438 - incorrect permissions in /etc/resolv.conf while running pptp
Summary: incorrect permissions in /etc/resolv.conf while running pptp
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pptp
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 17:50 UTC by Luis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-08 19:09:55 UTC


Attachments (Terms of Use)

Description Luis 2005-06-02 17:50:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When you run the program it creates e new /etc/resolv.conf file replacing the old one.
But the new one has owner and group =root and permissions 0077.
It should be 0022. Otherwise, only root can resolv adresses

Version-Release number of selected component (if applicable):
pptp-1.6.0-5.fc3

How reproducible:
Always

Steps to Reproduce:
1.Start the program
2.ls -l /etc/resolv.conf
3.
  

Actual Results:  -rw-------  1 root root 25 jun  2 19:19 /etc/resolv.conf

Expected Results:  -rw-r--r--  1 root root 25 jun  2 19:20 /etc/resolv.conf

Additional info:

Comment 1 Paul Howarth 2005-06-02 19:56:01 UTC
How are you running pptp? What options are you passing to it?

/etc/resolv.conf is not actually modified by pptp itself but by pppd, so if
anything it's likely that there's a problem there or with an if-up script you're
using.

Comment 2 Luis 2005-06-08 19:09:55 UTC
Ok, it is not a bug in Fedora Extras, I used the pptpconfig-20040722-6 package
from  sourceforge to have a graphical frontend. It is this program who actually
changes the /etc/resolv.conf from /var/run/ppp/resolv.conf

If I use the command line
pppd debug updetach logfd 1 linkname MYNET-i dump noauth
refuse-chaprefuse-mschap name MYNET\\myself remotename  MYNET-i ipparam MYNET-i
nobsdcomp nodeflate usepeerdns pty "pptp  130.206.5.5 --nolaunchpppd debug dump"

everithing works ok as long as it does not change the /etc/resolv.con

Comment 3 Paul Howarth 2005-06-09 08:34:03 UTC
Since I'm also the maintainer of the upstream packages, I still have an interest
in this. Could you please report this issue on the pptpclient-devel mailing list?

pptpclient-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/pptpclient-devel


Comment 4 Luis 2005-06-12 13:43:57 UTC
I found the origin of the problem. A custom /etc/bashrc that sometimes sets
incorrect masks, I realized when I started to have similar problems with another
program. After replacing it by the default fedora /etc/bashrc everyting works fine


Note You need to log in before you can comment on or make changes to this bug.