Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159428 - [PATCH] sysreport should not collect device nodes
Summary: [PATCH] sysreport should not collect device nodes
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysreport
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 17:01 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-04 14:20:32 UTC


Attachments (Terms of Use)
don't include any block or char device nodes in the sysreport (deleted)
2005-06-02 17:01 UTC, David Lehman
no flags Details | Diff

Description David Lehman 2005-06-02 17:01:51 UTC
Description of problem:
sysreport collects device nodes if present from $DNSDIR/dev and
/proc/scsi/qla2300 as a consequence of collecting the /proc/scsi and $DNSDIR/
recursively. This is a problem because it means you need to be root to unpack
the sysreport.

Version-Release number of selected component (if applicable):
sysreport-1.3.7.2-4

How reproducible:
Always

Steps to Reproduce:
1. Run sysreport on a system with qla2300 or a bind chroot set up
2. Try to unpack the sysreport as an unprivileged user 
3.
  
Actual results:
tar fails trying to create device nodes

Expected results:
sysreports should be collected such that they can be unpacked by non-root users

Additional info:

Comment 1 David Lehman 2005-06-02 17:01:51 UTC
Created attachment 115097 [details]
don't include any block or char device nodes in the sysreport

Comment 3 Ngo Than 2005-10-04 14:20:32 UTC
This feature is now included in sysreport-1.4.2-3 from, which will be added in 
next comming RHEL5 release. 
 
In my opinion it's not worth to add it in RHEL3 update. 


Note You need to log in before you can comment on or make changes to this bug.